It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Confirmed = Game Works wonderfully on windows 10 pro Creators edition even with SOFT SHADOWS ENABLED

Only problem is Movies play in 640c480 and look very stretched on my monitor!
I tried every suggestion here and still can't make it work, the game crashes on startup. The system scan on swconfig fails on OS (obviously, as it only recognizes up to XP) and OpenGL (with the error message: "Required: Non-Windows Generic OpenGL 1.4.0 drivers").

Any other suggestions? What about this OpenGL error, is that something that should be expected like the OS error?
Thank you, Lurtz! Worked for me, too.
Hey, I managed to get my working on Windows 10 Version 10.0.17134 Build 17134 by setting compatability mode to WIndows 98/Me. This was after having tried a host of other changes. Running a non-patched/modded version of KoToR II. Cheers.