It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
EDIT: I found a better solution to the stretching problem. Just read posting no 3.

Original posting:

dgvoodoo is a great thing. it pretty much solves the hardware acceleration issue. Sadly it either stretches the image or does not scale it at all. Therefore menus and cutscenes are either stretched or too small.

But, there is a solution. In the dgvoodoo readme there is a passage about this issue:

"Introducing 'unspecified' scaling mode. If you want to apply 'scaling but keeping aspect ratio' then select it on your graphics driver control panel and select 'unspecified' mode in dgVoodoo Setup. If it does not work then your only chance is forcing it through the graphics control panel (it all seems to be a Windows issue)."

Well, forcing aspect ration in the NVIDIA control panel + "unspecific" scaling mode did nothing. The image still got stretched. So I switched scaling in the NVIDIA control panel from GPU to Monitor. That way the monitor handles scaling. Guess what, it worked. I now have menus and cutscenes in 4:3 @ 640 x 480 and my 3D gameplay @ 1440p in 16:9.

There is a limitation though (there always is): Your monitor has to support aspect ratio handling. My Dell U2711 can do it. My LG 30" monitor could not. So it isn't even about the money you have spent on your screen. But if you have this option, it pretty much solves this issue. And maybe dgvoodoo will implement this feature in the future.
Post edited January 28, 2015 by Silver83
Great you got it sorted.

So far non of the beta testers could make it work. ;)
Post edited January 28, 2015 by teleguy
It gets better. I found an even better solution:

You don't need a monitor that can handle aspect ratio control. You just have to check an option in the NVIDIA control panel to ignore games' and programs' own scaling routines. I don't know the english description, so I attached a picture of it. That way EVERYONE with an NVIDA graphics card can now enjoy JK with dgvoodoo the best way possible. No stretching at all!
Attachments:
001.jpg (343 Kb)
Post edited January 28, 2015 by Silver83
avatar
Silver83: It gets better. I found an even better solution:

You don't need a monitor that can handle aspect ratio control. You just have to check an option in the NVIDIA control panel to ignore games' and programs' own scaling routines. I don't know the english description, so I attached a picture of it. That way EVERYONE with an NVIDA graphics card can now enjoy JK with dgvoodoo the best way possible. No stretching at all!
Unfortunately, this option (as well as many other NVIDIA Control Panel options) is not available on laptops. I'm told it has something to do with Optimus configurations, so I wouldn't know what to do.
avatar
Gibbagobba: Unfortunately, this option (as well as many other NVIDIA Control Panel options) is not available on laptops. I'm told it has something to do with Optimus configurations, so I wouldn't know what to do.
I had exactly this problem, so I couldn't get an unstretched picture using dgVoodo. The only option seemed to be playing at 1280x1024 with the "centered" option which at least comes close to an aspect ratio-correct image on a 1920x1080. Does anyone have any idea how to fix this?

Meanwhile, I could get the game running as I liked it using the unofficial patch as explained by jnisbet here: https://www.gog.com/forum/star_wars_dark_forces_series/jedi_knight_mots_hardware_acceleration_graphic_patches_for_all/post175
This way the 32bit resolution also automatically uses a stretched image with correct aspect ratio on my notebook, very nice.
avatar
Gibbagobba: Unfortunately, this option (as well as many other NVIDIA Control Panel options) is not available on laptops. I'm told it has something to do with Optimus configurations, so I wouldn't know what to do.
avatar
Syrion: I had exactly this problem, so I couldn't get an unstretched picture using dgVoodo. The only option seemed to be playing at 1280x1024 with the "centered" option which at least comes close to an aspect ratio-correct image on a 1920x1080. Does anyone have any idea how to fix this?

Meanwhile, I could get the game running as I liked it using the unofficial patch as explained by jnisbet here: https://www.gog.com/forum/star_wars_dark_forces_series/jedi_knight_mots_hardware_acceleration_graphic_patches_for_all/post175
This way the 32bit resolution also automatically uses a stretched image with correct aspect ratio on my notebook, very nice.
Since then, I just play the game at that same resolution but with windowed mode on. Makes it easier to record/stream as well.