It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I'm testing the French and German versions for my Spanish translation project of this Enhanced CD version.

In the English version, I can go to in-game options of Kirk->Text Display and change the method to display subtitles. These are: "Display subtitles", "Show until enter key pressed" or "only voiceovers".

I CAN NOT do this in French or German version. I click in "Text Display" and it does not show the three options that appears in the English version.

Anybody has been succesfull on make this options working in the French and German versions?

Thanks again.

Best regards,
David.
Was this a GOG version only bug or also in the original CD ROM version?

EDIT: just tested on a CD ROM original version and the answer is YES, was a bug of the original game :(
Post edited September 24, 2020 by hexaae
I've read ScummVM will add support for Star Trek: 25th Anniversary...
Maybe we'll finally have a chance to add unofficial localization support for extra languages without the serious issues and limitations when patching the original game.
I started a thread on ScummVM forum too: https://forums.scummvm.org/viewtopic.php?f=19&t=15253
avatar
hexaae: Was this a GOG version only bug or also in the original CD ROM version?

EDIT: just tested on a CD ROM original version and the answer is YES, was a bug of the original game :(
I'm also affected by that bug. It would be helpful if we could know where in the savegame the value for the option 'text display' is stored. Knowing that, we could at least modify it's value with a hex editor!

Maybe someone can post three savegames, each loaded from a master save, one for each value of 'text display'? We should be able to see where the option is stored and change it by hand once.

Or could someone post savegame from game start where simply the text option is set to 'show until enter key pressed'?

EDIT: I figured out that those settings are not stored in the savegame, so it won't help. If we find a hotkey for changing text mode, then we could use that. Otherwise as workaround: hit CTRL-S (or use game options) to disable sound, that way you can at least read the text because without sound, the text boxes won't disappear on their own.
Post edited November 22, 2020 by svarni