It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
AvatarX001: Ended up trying it in another PC and it this one It don't has this bug. Quite odd. But on the one that gets this bug. Bug it just unfixable no matter what. Really weird.
avatar
Brewtal_Legend: Any major differences between the pc's? Different operating systems? Internet connection?

I'm curious. I'm on win xp myself.
Both are on up to date Windows10. The bug happened to me on the GPD WIN 1 R1 (Atom X7 Z8700). But there have been people who played it fine on the GPD WIN 1 R2 (Atom X7 Z8750)

The bug was not present on my Transformer Book T300LA. I did nothing different other than in the GPD WIN 1 I used GOG Galaxy to install it. On the T300LA I used the backup file to install it and then I synced it with GOG Galaxy after I had seen it loaded fine and didn't had the death bug.
Hey, guys! I had the same problem with freezing on death screen for some time, then tried to play it offline, and once I died with my internet off, I was able to play it with internet connection on as it should be. Maybe this will help.
avatar
Poison_Alice: Hey, guys! I had the same problem with freezing on death screen for some time, then tried to play it offline, and once I died with my internet off, I was able to play it with internet connection on as it should be. Maybe this will help.
What? really?

what hardware were you on?

Will do test it again though.
avatar
Poison_Alice: Hey, guys! I had the same problem with freezing on death screen for some time, then tried to play it offline, and once I died with my internet off, I was able to play it with internet connection on as it should be. Maybe this will help.
avatar
AvatarX001: What? really?

what hardware were you on?

Will do test it again though.
I have an old core2duo laptop with Windows7sp1 and xbox360 controller. Already finished the game.
avatar
AvatarX001: What? really?

what hardware were you on?

Will do test it again though.
avatar
Poison_Alice: I have an old core2duo laptop with Windows7sp1 and xbox360 controller. Already finished the game.
Didn't worked for me in the GPD WIN 1. But I like I said, I installed it on the T300LA and played it fine there.
avatar
Poison_Alice: Hey, guys! I had the same problem with freezing on death screen for some time, then tried to play it offline, and once I died with my internet off, I was able to play it with internet connection on as it should be. Maybe this will help.
I tried this today (September 16, 2018) and it did not work for me.
I put my laptop into airplane mode, then started the game. I died at the very first lava pit and got the "You have been slain" screen. The game was completely unresponsive after that. The music and the animations still played. I had to alt+F4 out of the game.
This happens whether I have networking enabled or not.

I have a windows 7 laptop with an nvidia 980M and my drivers are up to date.

Update:
I just tried this in manjaro linux in a vm and the game automatically went past the "You have been slain" screen and brought me back to the checkpoint as I would expect.
Now I will have to get my sound working in the vm. That is probably not an issue with this game.
I still wish I could play in windows, but if I can play in my vm, I will be content.

Update Update:
sound issue fixed. it was unrelated to this game. The game plays fine on linux.
Post edited September 16, 2018 by psilocybin665
Just purchased during the current weekend promo. So, apparently this is still an issue. Game will not restart after death. Requesting refund.
It's 2019 and it still remains an issue... Unbelievable.
Add another person who run into same issue. Windows 7 user, tried playing while disconnected to internet, doesn't work.
avatar
KuruniXD: Add another person who run into same issue. Windows 7 user, tried playing while disconnected to internet, doesn't work.
Same here, even with internet connection.
Like lots of people, I have the same issue on a win 7 64 bits. It works fine on a Win 10 up to date. Usually, I don't use Galaxy but it allows to donwgrade the version of the game. And... surprise it works again in 1.25 version of the game. I lose some improvements but now it works. I hope it may help.