It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Thanks, selecting "prefer ffdshow over LAV" indeed works!
Darucas: I've got the same crash with the K-Lite codec pack installed. As expected, Silver is in the exception lists (for video and audio) but it still crashes. Moving the videos elsewhere works though, thanks!
Gowor: This is a codec issue. I had the same problem and fixed it by reinstalling K-Lite Codec Pack, selecting ffdshow where possible.

IIRC "Other video formats" was critical. "prefer LAV over ffdshow" crashed the game, while "prefer ffdshow over LAV" was OK.
Been having the Exception Access Violation game crashing error and removing the 4 avi files only allowed game to start but clicking the START *game* brought up that error again and game crashed. After reading this about k-lite; I uninstalled k-lite codecs and Reinstalled both the 32 and 64 bit versions of the newest k-lite codec packages and as suggested selected ffdshow over Lav ... OK-FINE ... REINSTALLED the SILVER game and clicked on it and the game started right up and played the Intro movie (I did Not remove the avi files this install). SO. the intro movie plays but then BLACK SCREEN and the little error box pops up again saying Exception Access Violation ... and game STILL will not play. SOOOOOO CLOSE but No dice .... I am going to remove those avi files now and try the game One More Time ... IF IT WORKS with the avi files removed PLUS the k-lite fixes I will be right back and say it works if it doesn't ... I will keep trying to figure this out until it does.
Simbabluenobi: snip
If the intro plays (first the Infogrames logo, then another video), then codecs are OK, and this is a next issue. I guess your crash happens when the game tries to render the main menu. What video card and driver version do you have?
At first, sorry for my bad English.
This thread should be treated as NOT SOLVED, because the "solution" suggested here didn't work for me. I tried to start the game in every possible compatibility mode (XP, win2000, Vista, and even Win95), but with no success. I moved the avi files to another partition of my hard disk, but again no success.
In all related cases, the game actually starts, shows the intro movies, and even shows the main menu!! I can even choose different configurations in the options menu, and go back to main, and when I click on Play, the screen turns black, a spinning tinny 3d model shows in the upper left corner of the screen for a few seconds, and the screen freezes. I need to go to the desktop and finish the silver32.exe by hand, via task manager.
Where is the link to a customer care service???????
piduca: snip
It might be a problem with notebook integrated video card.
What video card do you have?
The issue that causes a crash when clicking start is caused by DEP. As a workaround, you can add silver.exe to the DEP exclusion list or switch DEP to essential programs only. (On win7, that's control panel \ system \ advanced settings \ the settings button in the performance box \ data execution protection.)

Edit: But if you switch it to essential programs only, remember to switch it back at some point. Security features are there for a reason.

Thanks to Sraew for testing that one for me.
Post edited May 17, 2012 by timeslip
timeslip: The issue that causes a crash when clicking start is caused by DEP. As a workaround, you can add silver.exe to the DEP exclusion list or switch DEP to essential programs only. (On win7, that's control panel \ system \ advanced settings \ the settings button in the performance box \ data execution protection.)

Thanks to Sraew for testing that one for me.
GAME IS WORKING ... Thanks to you and the GOG Team .Uninstalling and reinstalling the k-lite codec pack as mentioned by the GOG Team in above post and changing the DEP settings as you said has gotten SILVER to run (with the avi files still in the intro folder so the movies work as well) ...

I am using an integrated intel41 graphics chip in this (quick-replacement) computer without a dedicated graphics card and 99% of all the games purchased on GOG works thanks to GOG's and community members help.

These TWO FIXES ,,, the k-lite fix and the DEP setting the usual fixes like run as administrator and install OUTSIDE of the windows Program folder should be stickied at the start of this forum ... PLUS it is running in Windows 7 and NOT using the compatability mode ... GAME WORKS !!! ... even on a Walmart emachine *special* ... :)

Post edited May 17, 2012 by Simbabluenobi
Thanks, I was wondering why I couldn't see the Intro vids. The codec fix worked well. Can you guys patch this up eventually? Like convert the videos or something in a future version. Also I bought this yesterday, didn't play very much yet. However, I saw some worrying reports of bugs related to CPU clock speed. Thanks for the help!
Just to add to the codec fix:

I've found that selecting "prefer ffdshow over LAV" during the K-Lite installation is an issue for games like Thief. Given that Silver is the only one having issues for me with the default setting (LAV over ffdshow), keeping this default setting may be better.

So for Silver, as the cutscenes (.avi) use Indeo3, you can enable this format in the ffdshow video decoder (in Start=>K-Lite =>Configuration=>ffdshow video decoder=>Codecs) - select "libavcodec" for Indeo 3. So that without changing the default install setting, you can play both Thief (and others?) and Silver without crashing in any game. Maybe this will help those who don't want to reinstall the pack.
I'm having the same problem, but removing the videos didn't work. it happens a little after i go into the barracks for the first time. then the game crashes, and the "Acess violation" appears.
Have you tried the new .10 patch from "extra" downloads?
Here's another and simple solution:

Just unmark "Don't use ffdshow in:"

And done. Now you can play Silver without problems. :D
silver.jpg (74 Kb)
Post edited July 08, 2012 by pacciulli
I have a similar problem. Except for the access violation error. Tried all mentioned fixes. Still can't see the intro and the "paus command" don't work for me. When i push F12 my screen turns black.

-updated to latest grafx version (Nvidia)
-Run as administrator
-tweaked and updated the codex settings
-tested different compatible modes
-Fixed the DEP setting

Seems like I've run out of choices...any suggestions?
hi i just downloaded silver...and i tried to launch the game but an error saying: access violation appeared...what do i have to do to fix this ? i am not very computer genius so i dont know much on how to resolve an issue such as this one... can some1 help me out ??

dude i just downloaded this and just left a having a problem wen i try to launch the game...its says access violation...a bit annoyed coz i wasted my money and cant play...also im not very computer genius so i dont rly kno many terms and how to fix problems like this...what do i have to do ??

Post edited July 29, 2012 by zmk1990
also....i downloaded everything separately so i dont have a folder an a file named: data ?! how weird... can some1 help me out ?