It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hello fellow Debian users, Ubuntu lovers and Mint freaks!

Here you’ll find scripts allowing you to build a .deb package from your Windows installer for Alpha Centauri. You can install it through DPKG and remove it through any APT front-end (apt-get, aptitude, synaptic, etc.).

The game run on the native Loki engine.

Download links and usage instructions can be found on the following page:
Sid Meier's Alpha Centauri

I hope you’ll enjoy the comfort provided by these scripts as much as I enjoy writing and tweaking them ;)

Here you go for more supported games!

-----

Salut camarades Debianistes, Ubunteros et fanas de Linux Mint !

Vous trouverez ici des scripts vous permettant de construire un paquet .deb à partir de votre installeur pour Windows de Alpha Centauri. Vous pouvez l’installer via DPKG et le supprimer via n’importe quelle interface à APT (apt-get, aptitude, synaptic, etc.).

Le jeu tourne avec le moteur natif publié par Loki.

Les liens de télechargement et les instructions d’utilisation se trouvent sur la page suivante :
Sid Meier's Alpha Centauri

J’espère que vous apprécierez le confort apporté par ces scripts autant que j’apprécie les écrire et les améliorer ;)

Pour plus de jeux, rendez-vous par ici !
Post edited October 09, 2017 by vv221
Hello, thanks for writing the script for SMAC, I really enjoy your work. I have a slight problem though, there's no sound. Running the alpha-centauri or alpha-centauri_smacx command from the terminal I get this information:

petar@marija:~$ alpha-centauri
ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default
petar@marija:~$ alpha-centauri_smacx
ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default
petar@marija:~$

So yeah, the game starts, and runs fine, except there is no sound. I didn't look around for solutions on the internet, because I think I should give you feedback, so you could improve your scripts.
avatar
neskromanser: (…)
I have seen the same problem when pulseaudio is installed, and uninstalling it did fix it.
As I ususally don’t use it, I don’t know how you can temporarily disable it while the game is running, but if someone can give me the command used for that (is it "pasuspend" or something similar?) I’ll add an automatic suspend of pulseaudio when you run the game.
avatar
vv221: As I ususally don’t use it, I don’t know how you can temporarily disable it while the game is running, but if someone can give me the command used for that (is it "pasuspend" or something similar?) I’ll add an automatic suspend of pulseaudio when you run the game.
You mean pasuspender? Believe this is sufficient:
pasuspender -- command
Likely would be better to test it first.
I tried using the pasuspender -- alpha-centauri command, but it gives me the same error like the regular alpha-centauri command

petar@marija:~$ pasuspender -- alpha-centauri
ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default
petar@marija:~$

So it basically does nothing for the sound.
Right, I remember now that not having PulseAudio running was not enough: I needed to not have it installed to get sound.
There must be some work-around, I’ll work on this.
A just made Archlinux port: https://github.com/Amadren/play.it

Edit: Updated the smac script with a fix for the sound bug.
Post edited April 29, 2016 by Amadren
avatar
neskromanser: (…)
Try loading the 'snd_pcm_oss' kernel module before running the game:
sudo modprobe snd_pcm_oss

Does it fix your problem of missing sound?
avatar
neskromanser: (…)
avatar
vv221: Try loading the 'snd_pcm_oss' kernel module before running the game:
sudo modprobe snd_pcm_oss

Does it fix your problem of missing sound?
That fixed it, thanks so much!
I made a script to fix the sound bug and auto-load "snd_pcm_oss" at each restart

Here it is: https://github.com/Amadren/play.it/blob/master/Games/Sid-Meier-s-Alpha-Centauri/sound_fix.sh

Click on raw, download it, make it executable and run it using sudo.

It will work on any distribution.
avatar
Amadren: (…)
And here you go for a direct download link:
https://github.com/Amadren/play.it/raw/master/Games/Sid-Meier-s-Alpha-Centauri/sound_fix.sh
avatar
Amadren: A just made Archlinux port: https://github.com/Amadren/play.it

Edit: Updated the smac script with a fix for the sound bug.
Just wanted to say "Thanks!", this works great on my Antergos install :)
avatar
vv221: The game run on the native Loki engine.
Where do you get that engine from? Is the source code for it available?
avatar
eiii: (…)
You can download the engine from my website, check the link in the opening post to find it.

I’ve extracted it from an original Loki SMAC fully patched installation, the sources for it are not available. This engine is *not* open-source.
avatar
vv221: You can download the engine from my website, check the link in the opening post to find it.
I've seen that I can download it from your website. But that wasn't my question.

avatar
vv221: I’ve extracted it from an original Loki SMAC fully patched installation, the sources for it are not available. This engine is *not* open-source.
Is the engine freely redistributable or is this some kind of "gray zone"?
Post edited May 12, 2016 by eiii