It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
musashiden: (…)
avatar
vv221: There is now a bug report on our issues tracker, a fix should be included in the next ./play.it update: Debian packages building fails with restrictive umask
I confirm: it works ! thank you very much for your support.

So my umask is indeed 027 and switching to 022 did the trick.

Just to let you know that doing
> umask 022
> TMP_DIR=./tmp ./aply-shadow-tactics.sh
did not work: I had the cp error

Best regards
avatar
vv221: There is now a bug report on our issues tracker, a fix should be included in the next ./play.it update: Debian packages building fails with restrictive umask
avatar
musashiden: I confirm: it works ! thank you very much for your support.

So my umask is indeed 027 and switching to 022 did the trick.
Nice, we should have a fix soon ;)

---

avatar
musashiden: Just to let you know that doing
> umask 022
> TMP_DIR=./tmp ./aply-shadow-tactics.sh
did not work: I had the cp error
I guess you spotted another bug here, I do not think we ever checked what would happen when not using an absolute path for $TMPDIR.
avatar
musashiden: …/tmp/shadow > TMPDIR=./tmp ./play-shadow-tactics.sh
Utilisation de shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh
Contrôle de l’intégrité de shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh OK
Extraction des données de shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh OK
cp: avec --parents, la destination doit être un répertoire
Saisissez « cp --help » pour plus d'informations.
This bug is now tracked, and some fixes have already been proposed: organize_data fails files copy when TMPDIR is set using a relative path

Thanks again for your help in spotting it ;)
Post edited April 15, 2020 by vv221
avatar
musashiden: (…)
We now have a fix ready to make sure .deb packages can be built even when a restrictive umask is in effect: Library fix: Enforce correct permissions for .deb packages metadata

This is going to be part of our 2.11.4 bugfix release.
Post edited April 17, 2020 by vv221
Update

• Add missing dependencies
When PulseAudio is running, ALSA plugins are required to get working audio.