It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello fellow Linux gamers!

Here you can find informations about ./play.it, a tool building packages for Debian, Arch Linux, Gentoo and any derivative (Ubuntu, Manjaro, Linux Mint, etc.) from your installers for Shadow Tactics: Blades of the Shogun.
These packages can be installed easily with your favourite packages manager.

Download links and usage instructions can be found on the following page:
Shadow Tactics: Blades of the Shogun

We hope youʼll enjoy the ease-of-use provided by this tool as much as we enjoy writing and tweaking it ;)

Here you go for more supported games!

-----

Salut camarades Linuxiens !

Vous trouverez ici des informations à propos de ./play.it, un outil construisant des paquets pour Debian, Arch Linux, Gentoo ou nʼimporte quelle distribution dérivée de celles-ci (Ubuntu, Manjaro, Linux Mint, etc.) à partir de vos installateurs pour Shadow Tactics: Blades of the Shogun.
Ces paquets sʼinstallent facilement via votre gestionnaire de paquets habituel.

Les liens de téléchargement et les instructions dʼutilisation se trouvent sur la page suivante :
Shadow Tactics: Blades of the Shogun

Nous espérons que vous apprécierez le confort apporté par cet outil autant que nous apprécions lʼécrire et lʼaméliorer ;)

Pour plus de jeux, rendez-vous par ici !
Post edited September 16, 2020 by vv221
Update

Add missing dependency on libudev.so.1
Update

New supported installer:
shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh
Thank you fellow french gamer for this fantastic works !

After struggling to install this game on Debian (game crashing immediately after starting), I'm finally able to enjoy it on Linux.

I will definitely check your other work and maybe help you if I can :)
avatar
Ir0n_Wolf: (…)
Thanks, it’s pleasing to see it helped you getting this game to work without hassle ;)

If you’re serious about the helping us part, what we’re mostly looking for right now is people adding support for new games. So the best help you can give us is writing ./play.it scripts for your favourite games!
If you want some help in doing this, you can join us on our IRC channel (#play.it on Freenode), or drop an e-mail to the address that can be found in the Shadow Tactics script. On both channels, French speaking is welcome as well as English.
Hi,

Not working for me :(

Utilisation de shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh
Contrôle de l’intégrité de shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh OK
Extraction des données de shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh OK
Construction de shadow-tactics_2.2.10.f-gog21297+20181102.2_i386.debdpkg-deb: erreur: le répertoire de contrôle n'a pas les bonnes permissions 750 (doit être >=0755 et <=0775)

Anybody has a clue ?

Best regards
avatar
musashiden: (…)
The following error:
dpkg-deb: erreur: le répertoire de contrôle n'a pas les bonnes permissions 750 (doit être >=0755 et <=0775)
seems to indicate that some directories used for building the final .deb package use non-standard permissions.

I guess this might happen if you try to build packages from an external drive or USB stick. Is that the case?
Thanks for your quick reply

no I'm in my home folder:

~/tmp >ls -l | grep shadow
drwxr-xr-x 2 alex alex 4096 avril 10 12:21 shadow
~/tmp >cd shadow
…/tmp/shadow >ll
total 3,8G
-rwxr--r-- 1 alex alex 130K avril 10 12:13 libplayit2.sh
-rwxr--r-- 1 alex alex 4,1K avril 10 12:13 play-shadow-tactics.sh
-rwxr--r-- 1 alex alex 3,8G avril 10 11:49 shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh
…/tmp/shadow >./play-shadow-tactics.sh Utilisation de shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh
Contrôle de l’intégrité de shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh OK
Extraction des données de shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh OK
Construction de shadow-tactics_2.2.10.f-gog21297+20181102.2_i386.debdpkg-deb: erreur: le répertoire de contrôle n'a pas les bonnes permissions 750 (doit être >=0755 et <=0775)
…/tmp/shadow >chmod 755 *sh
…/tmp/shadow >ll
total 3,8G
-rwxr-xr-x 1 alex alex 130K avril 10 12:13 libplayit2.sh
-rwxr-xr-x 1 alex alex 4,1K avril 10 12:13 play-shadow-tactics.sh
-rwxr-xr-x 1 alex alex 3,8G avril 10 11:49 shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh
…/tmp/shadow >./play-shadow-tactics.sh
Utilisation de shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh
Contrôle de l’intégrité de shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh OK
Extraction des données de shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh OK
Construction de shadow-tactics_2.2.10.f-gog21297+20181102.2_i386.debdpkg-deb: erreur: le répertoire de contrôle n'a pas les bonnes permissions 750 (doit être >=0755 et <=0775)

I'm using Debian buster
avatar
musashiden: (…)
OK, so the issue is happening elsewhere.

Do you have a directory /tmp/play.it created by ./play.it?
If this directory exists, please give us the return of:
ls -ld /tmp/play.it/shadow-tactics.*/shadow-tactics_2.2.10.f-gog21297+20181102.2_i386/DEBIAN
This "shadow-tactics_2.2.10.f-gog21297+20181102.2_i386/DEBIAN" directory seems to be the one with permissions issues, and it should be found in one of the following paths:
- /run/user/1000/play.it
- /tmp/play.it
- ~/.cache/play.it
- ~/tmp/shadow/play.it

If we can find why it is not created with the right permissions, we should be able to find a way to update ./play.it to avoid it happening, or at least to display a more explicit error message with instructions about how to work around it.

---

Note to myself:
In case it may help in searching what goes wrong, here is the English version of the error message you get:
dpkg-deb: error: control directory has bad permissions 750 (must be >=0755 and <=0775)
Indeed

>ls -ld /tmp/play.it/shadow-tactics.mhoAj/shadow-tactics_2.2.10.f-gog21297+20181102.2_i386/DEBIAN

drwxr-x--- 2 alex alex 4096 avril 11 13:47 /tmp/play.it/shadow-tactics.mhoAj/shadow-tactics_2.2.10.f-gog21297+20181102.2_i386/DEBIAN
Post edited April 11, 2020 by musashiden
avatar
musashiden: (…)
There is no reason for this directory to be created with such permissions, so this might be due to the way /tmp is mounted on your system.

Please share the return of the following command, it should tell us if there are specific mount options that are used and are messing around with what happens under /tmp:
findmnt
avatar
musashiden: (…)
Since your issue is probably specific to the use of /tmp to build the packages, it might not happen if you override TMPDIR when you run the script, by giving it another path like the one you use to build the packages:
TMPDIR=~/tmp/shadow ./play-shadow-tactics.sh
By the way, ./play.it may have left files in /tmp after its failure, you can delete them to reclaim storage space:
rm -r /tmp/play.it
Sorry for the delay

It helped ! But unfortunately it was not enough:

…/tmp/shadow > TMPDIR=./tmp ./play-shadow-tactics.sh
Utilisation de shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh
Contrôle de l’intégrité de shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh OK
Extraction des données de shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh OK
cp: avec --parents, la destination doit être un répertoire
Saisissez « cp --help » pour plus d'informations.
…/tmp/shadow > ls
libplayit2.sh play-shadow-tactics.sh shadow_tactics_blades_of_the_shogun_en_2_2_10_f_21297.sh tmp

The first command finished with exist status code = 1

That is strange regarding /tmp, I don't see it as a mount point. And I'm pretty sure I did not do anything special about it

maybe we can continue this discussion in private and post a recap here at the end ?
Post edited April 14, 2020 by musashiden
avatar
musashiden: maybe we can continue this discussion in private and post a recap here at the end ?
It is actually for the best if everything stay public, it is going to make it easier for me to have all informations to fix the bug in one place in the end ;)

I am going to run some tests to try and replicate your issue, then I am coming back to you, hopefully with a well-tested work-around.

---

Another informations that may help me, what is the return of the following command on your system?
umask
---

Got it, I replicated your issue and found a work-around ;)

Here you go:
umask 0022
./play-shadow-tactics.sh
If it works for you, I am going to fix the library to enforce this umask value when building packages.
Post edited April 14, 2020 by vv221
avatar
musashiden: (…)
There is now a bug report on our issues tracker, a fix should be included in the next ./play.it update: Debian packages building fails with restrictive umask