It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Had gotten this for Steam recently (bundle somewhere for 90 cents (Euro)) and was disappointed to see it running at only 10 FPS, this wonderful fix brings it up to a whopping 21 FPS :) which at least makes it playable for me.

Thank you.
Seems like it if you enable "Windows 98/ME" compatibility mode for game.exe, the fps is limited.
Best option is to disable compatibility mode on Win7/Win8.

Also if you lower the ingame resolution, performance is better (would make sense, but these days 1024x768 is not that high demanding for new videocards).


Up until now, the best working Robin Hood version (without any lag) i've played with so far is the Linux port that can be found on Desura.
Is there any fix for Windows 8? Game is pretty much unplayable for me.
avatar
MhidDa: You all rule. I thought I was out of luck with this purchase from steam, they just wrote it off as video card incompatibility and pretty much sent out a big FU to those of us who it didn't run for. It runs great now thanks to you. You just got yourself a convert...
Yeah. Same here. Only game I asked for a refund on steam for, and that was my only chance according to them. Stupid policy when the game doesnt friggin work. Oh well, guess I used up my only chance of a refund for a 10 dollar game :)

Thanks GoG guys for figuring out and fixing this problem. Will buy soon.
So... The fix works only for windows 7 or work for windows 8.1 too? I finished commandos 1 and his expansion and commandos 2 so many times and only a few days ago i found this game... OH GOD, I NEED TO PLAY THIS GAME!!
Post edited April 14, 2015 by Umarugyn
Hello this fix is not working for me i have win 7 help!
avatar
Umarugyn: So... The fix works only for windows 7 or work for windows 8.1 too? I finished commandos 1 and his expansion and commandos 2 so many times and only a few days ago i found this game... OH GOD, I NEED TO PLAY THIS GAME!!
Ok Guys, i'm here to help, all you need to do is this:

1) Download the following... http://188.138.113.72/SHARE/rpollice/DSWin8.zip
1.1) Unrar the downloaded file (DSWin8.zip) and you should have two files in the extracted folder (ddraw.dll and aqrit.cfg).
1.2) Place these two files into your "Steam\SteamApps\Common\Robin Hood" directory (in with the game.exe).

2) Download V2_02_90_build.rar of DxWnd from... http://sourceforge.net/projects/dxwnd/files/Latest%20build/
(I've been advised by other users that the newer versions don't work for the purpose of running this game.)

3) Unrar and inside the extracted foler and run "dxwnd.exe" as administrator. Go to "Edit->Add", in parameter "Name" set the name as Robin Hood.
4) In parameter "Path" choose the .exe file of the game (in my case it looks like Steam\SteamApps\common\Robin Hood\game.exe).
5) In the "Main" tab, under "Generic" untick "Run in Window".
5.1) Also in "Main" tab, under "Position" set "Window initial position & size" to X=0 and Y=0. Set "W" and "H" to your native resolution (in my case that's W=1920 and H=1080).
6) In the "Video" tab, under "Windows handling" tick "Modal Style" and under "Color management" tick "Set 16BPP RGB565 encoding".
7) Next in "Input" tab tick "Hide Cursor". If the cursor flickers on the main screen of the game don't worry, it works fine in-game.
8) Lastly click "OK" in dxwnd, if all is good it will show a green circle before the name of the game in DxWnd. Launch the game in Steam (Not in DxWnd itself, DxWnd runs in the backround!). You may get an error/alert that says something like "SetHook: proc=GetAvailableVidMem(D) oldhook=26b3e0". If this happens just press the Return key on your keyboard. If you can't select the error/alert window use Alt+Tab keys to cycle through the open windows. This part is just a bit of a trial and error, I don't know why it happens but you can get past it.
9) You will need to start DxWnd every time before you launch the game. When you close dxwnd, answer "Yes" to save the options that you changed. That's it...

If need more help, feel free add me in the steam (/SmokeApe)
Thanks, tnis seems to work in WIn10 as well.

No kudos though to GOG who know this problem is in the game for at least three years.
avatar
Umarugyn: So... The fix works only for windows 7 or work for windows 8.1 too? I finished commandos 1 and his expansion and commandos 2 so many times and only a few days ago i found this game... OH GOD, I NEED TO PLAY THIS GAME!!
avatar
ScottiePrimo: Ok Guys, i'm here to help, all you need to do is this:

1) Download the following... http://188.138.113.72/SHARE/rpollice/DSWin8.zip
1.1) Unrar the downloaded file (DSWin8.zip) and you should have two files in the extracted folder (ddraw.dll and aqrit.cfg).
1.2) Place these two files into your "Steam\SteamApps\Common\Robin Hood" directory (in with the game.exe).

2) Download V2_02_90_build.rar of DxWnd from... http://sourceforge.net/projects/dxwnd/files/Latest%20build/
(I've been advised by other users that the newer versions don't work for the purpose of running this game.)

3) Unrar and inside the extracted foler and run "dxwnd.exe" as administrator. Go to "Edit->Add", in parameter "Name" set the name as Robin Hood.
4) In parameter "Path" choose the .exe file of the game (in my case it looks like Steam\SteamApps\common\Robin Hood\game.exe).
5) In the "Main" tab, under "Generic" untick "Run in Window".
5.1) Also in "Main" tab, under "Position" set "Window initial position & size" to X=0 and Y=0. Set "W" and "H" to your native resolution (in my case that's W=1920 and H=1080).
6) In the "Video" tab, under "Windows handling" tick "Modal Style" and under "Color management" tick "Set 16BPP RGB565 encoding".
7) Next in "Input" tab tick "Hide Cursor". If the cursor flickers on the main screen of the game don't worry, it works fine in-game.
8) Lastly click "OK" in dxwnd, if all is good it will show a green circle before the name of the game in DxWnd. Launch the game in Steam (Not in DxWnd itself, DxWnd runs in the backround!). You may get an error/alert that says something like "SetHook: proc=GetAvailableVidMem(D) oldhook=26b3e0". If this happens just press the Return key on your keyboard. If you can't select the error/alert window use Alt+Tab keys to cycle through the open windows. This part is just a bit of a trial and error, I don't know why it happens but you can get past it.
9) You will need to start DxWnd every time before you launch the game. When you close dxwnd, answer "Yes" to save the options that you changed. That's it...

If need more help, feel free add me in the steam (/SmokeApe)
This is, without a doubt, the best solution I could find. Amazing job, friend.
Thanks!
avatar
ScottiePrimo: Ok Guys, i'm here to help, all you need to do is this:

1) Download the following... http://188.138.113.72/SHARE/rpollice/DSWin8.zip
1.1) Unrar the downloaded file (DSWin8.zip) and you should have two files in the extracted folder (ddraw.dll and aqrit.cfg).
1.2) Place these two files into your "Steam\SteamApps\Common\Robin Hood" directory (in with the game.exe).

2) Download V2_02_90_build.rar of DxWnd from... http://sourceforge.net/projects/dxwnd/files/Latest%20build/
(I've been advised by other users that the newer versions don't work for the purpose of running this game.)

3) Unrar and inside the extracted foler and run "dxwnd.exe" as administrator. Go to "Edit->Add", in parameter "Name" set the name as Robin Hood.
4) In parameter "Path" choose the .exe file of the game (in my case it looks like Steam\SteamApps\common\Robin Hood\game.exe).
5) In the "Main" tab, under "Generic" untick "Run in Window".
5.1) Also in "Main" tab, under "Position" set "Window initial position & size" to X=0 and Y=0. Set "W" and "H" to your native resolution (in my case that's W=1920 and H=1080).
6) In the "Video" tab, under "Windows handling" tick "Modal Style" and under "Color management" tick "Set 16BPP RGB565 encoding".
7) Next in "Input" tab tick "Hide Cursor". If the cursor flickers on the main screen of the game don't worry, it works fine in-game.
8) Lastly click "OK" in dxwnd, if all is good it will show a green circle before the name of the game in DxWnd. Launch the game in Steam (Not in DxWnd itself, DxWnd runs in the backround!). You may get an error/alert that says something like "SetHook: proc=GetAvailableVidMem(D) oldhook=26b3e0". If this happens just press the Return key on your keyboard. If you can't select the error/alert window use Alt+Tab keys to cycle through the open windows. This part is just a bit of a trial and error, I don't know why it happens but you can get past it.
9) You will need to start DxWnd every time before you launch the game. When you close dxwnd, answer "Yes" to save the options that you changed. That's it...

If need more help, feel free add me in the steam (/SmokeApe)
avatar
Phoenix_mkd: This is, without a doubt, the best solution I could find. Amazing job, friend.
Thanks!
Tnx man, i hope you enjoyed the game
avatar
Umarugyn: So... The fix works only for windows 7 or work for windows 8.1 too? I finished commandos 1 and his expansion and commandos 2 so many times and only a few days ago i found this game... OH GOD, I NEED TO PLAY THIS GAME!!
avatar
ScottiePrimo: Ok Guys, i'm here to help, all you need to do is this:

1) Download the following... http://188.138.113.72/SHARE/rpollice/DSWin8.zip
1.1) Unrar the downloaded file (DSWin8.zip) and you should have two files in the extracted folder (ddraw.dll and aqrit.cfg).
1.2) Place these two files into your "Steam\SteamApps\Common\Robin Hood" directory (in with the game.exe).

2) Download V2_02_90_build.rar of DxWnd from... http://sourceforge.net/projects/dxwnd/files/Latest%20build/
(I've been advised by other users that the newer versions don't work for the purpose of running this game.)

3) Unrar and inside the extracted foler and run "dxwnd.exe" as administrator. Go to "Edit->Add", in parameter "Name" set the name as Robin Hood.
4) In parameter "Path" choose the .exe file of the game (in my case it looks like Steam\SteamApps\common\Robin Hood\game.exe).
5) In the "Main" tab, under "Generic" untick "Run in Window".
5.1) Also in "Main" tab, under "Position" set "Window initial position & size" to X=0 and Y=0. Set "W" and "H" to your native resolution (in my case that's W=1920 and H=1080).
6) In the "Video" tab, under "Windows handling" tick "Modal Style" and under "Color management" tick "Set 16BPP RGB565 encoding".
7) Next in "Input" tab tick "Hide Cursor". If the cursor flickers on the main screen of the game don't worry, it works fine in-game.
8) Lastly click "OK" in dxwnd, if all is good it will show a green circle before the name of the game in DxWnd. Launch the game in Steam (Not in DxWnd itself, DxWnd runs in the backround!). You may get an error/alert that says something like "SetHook: proc=GetAvailableVidMem(D) oldhook=26b3e0". If this happens just press the Return key on your keyboard. If you can't select the error/alert window use Alt+Tab keys to cycle through the open windows. This part is just a bit of a trial and error, I don't know why it happens but you can get past it.
9) You will need to start DxWnd every time before you launch the game. When you close dxwnd, answer "Yes" to save the options that you changed. That's it...

If need more help, feel free add me in the steam (/SmokeApe)
Man, thx a lot! The game finally works, and I've been trying to get rid of bugs for a couple of months! I should have checked this forum in the first place.

Thanks again!