It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

johntuck77: I have or better say had the same problem and here is how to solve it:
The patch never worked for me so I had to do it manually.
1) Download the following Hex Editor you can find it at this website
2) Install the editor and open your save game which you imported into ROA2. BEFORE YOU CHANGE ANYTHING MAKE A BACKUP COPY OF YOUR SAVEGAME.
3) You can either find it manually or by pressing Ctrl+F and look for the word "CHAR". It is usually located right before your characters name. Click the letter C of CHAR and make sure it is highlighted in the Hex editor as well.
4) Here comes the most important thing. Press Ctrl +G in the field type in +0xB7 this will take you about 5 lines further down from the word CHAR and you should see right where it lands or right next to it the number "10"
5) Replace the number 10 with 00 and save.
6) Repeat the previous steps for all your characters.

This should take care of the issue. BTW with this editor you can also change other values of your characters. All what you need for that is the windows calculator and know your character values.
I agree GOG should have either fixed the patch or given us this walkthrough. Good luck everyone and hope this helps.
EDIT: I figured out what was going wrong. The.GAM file that you put in the GAMES folder to import is NOT the one the game actually uses. The imported file is stored in the cloud_saves folder, which I didn't notice until now! My edits didn't work because the .GAM file I edited wasn't actually being used by the game anymore, it just sits in the GAMES folder unused, you can even delete with no consequences as far as I can tell.

The imported .GAM in the cloud_saves folder has the "CHAR" string before each character name and the 10 byte is offset from there the expected amount. Thanks to everyone who figured out this weird bug!

Has anyone had any success with this method recently? Just the other day I finished BoD and imported my save game into Star Trail but got the kid face bug.

I tried following the above steps but unfortunately there was no "CHAR" string in the save file. Instead I tried finding each character's name and changing the next closest 10 value to 00, but still no luck. I'm planning on trying to edit a few more 10 values that I can find after a character's name, but I'm not optimistic. If I have any success I will post here.

Was there a patch that changed the save game format? If anyone has any insight I'd be very grateful!
Post edited February 07, 2022 by ArnoDick