It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
In order to get the music working (as i've discovered), you need to use a custom game engine. I would prefer Quakespasm as it gives the most vanilla OpenGL experience, with the added bonus of music.
Download here: http://quakespasm.sourceforge.net/

Step 1: Download DAEMON tools Lite 10 for free here: https://www.daemon-tools.cc/downloads

Step 2: Mount the "game", "gamea" and "gamed" files from the Quake folder, as CD-discs using DAEMON tools.
game = Quake music
gamea = Quake: Scourge of Armagon music
gamed = Quake: Dissolution of Eternity music

Step 3: Open "Windows Media Player" and select one of the three discs, check all the songs, and set the "Rip" type to
WAV, and then Rip the CD files. The songs will then be available in your Windows Library under Music.

Step 4: Go into the Quake folder, then "Id1" and create a folder called "music". Drop all of the ripped music files here,
and make the "game" disc songs are named "track02.wav --- track11.wav" (There are 10 tracks in "game",
rename them all from 02 to 11, (for some reason)).

Step 5: Open the "Quakespasm" download folder, and drag all of the files into the default Quake folder, overwrite if
asked. Now you are good to go!

OPTIONAL: The songs are kinda ruind with a feature called "Pre-Emphasis", which makes high pitched sounds in the
music even higher, slising your eardrums with a knife of sound (OUCH!). To fix this, you can either rip the
songs using iTunes instead of Windows Media Player, since "De-Emphasis" is an automatic feature here.
Or, follow the guide video here: https://youtu.be/eF4GSsffbSE?t=3m11s

Enjoy your game, if you were able to launch GLquake! (I can't :()
When mounting the disc in WinCDEmu, what type of disc should I say that the bin-cue files are? Data Discs?
avatar
RadiactoR: Step 1: Download DAEMON tools Lite 10 for free here: https://www.daemon-tools.cc/downloads
OPTIONAL: The songs are kinda ruind with a feature called "Pre-Emphasis", which makes high pitched sounds in the
music even higher, slising your eardrums with a knife of sound (OUCH!).
Isn’t DAEMON tools spyware or something now? Everything I see says to use WinCDEmu now instead.
Also, the Pre-Emphasis is an intentional stylistic decision. De-emphasizing the music makes it duller. (See the top comment on your linked video)
Post edited November 16, 2018 by SirYodaJedi
Hi everybody. I'm still not hearing any music when playing the game, even though I did everything that I was supposed to do. I ripped the music into *.wav format, renamed the songs track02-track11, placed them in id1/music (I'm using Quakespasm btw). But still: no music. However, when I open the Quake command terminal and type "music track[02-11]", the corresponding track plays. So I know the music is in the right location. So why isn't it automatically playing when I start the game?

Something else I noticed in the terminal: one of its messages says "No CD inserted in drive" during sound configuration. Is there something extra I need to configure, so that it reads the wav files I created? Also, I have "External Music" set to "True."
avatar
MartyD82: Hi everybody. I'm still not hearing any music when playing the game, even though I did everything that I was supposed to do. I ripped the music into *.wav format, renamed the songs track02-track11, placed them in id1/music (I'm using Quakespasm btw). But still: no music. However, when I open the Quake command terminal and type "music track[02-11]", the corresponding track plays. So I know the music is in the right location. So why isn't it automatically playing when I start the game?

Something else I noticed in the terminal: one of its messages says "No CD inserted in drive" during sound configuration. Is there something extra I need to configure, so that it reads the wav files I created? Also, I have "External Music" set to "True."
Hey, that's a strange one. External music ON, music volume all the way up and it doesn't play in original campaign? Try to toggle external music off, save it, then on again and same with the volume. Other than that I have no idea. I remember reading that quakespasm recognises flac, mp3 and ogg files. I would imagine wav being a nobrainer too, but never have tried it.

Also I remember that there are 2 builds of quakespasm being provided. One is based on SDL1.2 (quakespasm12.exe) and offers cd audio, while the newer one is based on SDL2 and has cd audio disabled (it reads that during quake initialisation), but has enabled support for xinput gamepads and some new features (quakespasm.exe). I'm using the latter SDL2 build in combo with ogg files and it works no problems as intended. Vanilla install of quake+quakespasm, no mods (some mods have their own music in pak files and they can interfere with the playback).