It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi fellow gog members,
When I start a game of PG 2 many items on the map contain these multi colored pixels, is there some setting I can adjust to fix this?
I'm running Windows 7 64 bit, and as of the moment, using the on board graphics built into the motherboard. The on board graphics is a NVIDIA GeForce 6150SE nForce 430.
It also seems that my mouse freezes about half of the time when I get to the select campaign/scenario screen as well.
I see that a lot of gog games seem to be having trouble with Windows 7 :(
Thank you goggers!
This question / problem has been solved by damnitdanielimage
avatar
damnitdaniel: Hi fellow gog members,
When I start a game of PG 2 many items on the map contain these multi colored pixels, is there some setting I can adjust to fix this?
I'm running Windows 7 64 bit, and as of the moment, using the on board graphics built into the motherboard. The on board graphics is a NVIDIA GeForce 6150SE nForce 430.
It also seems that my mouse freezes about half of the time when I get to the select campaign/scenario screen as well.
I see that a lot of gog games seem to be having trouble with Windows 7 :(
Thank you goggers!

Hi Daniel,
I experience the precise same symptoms - discolored graphics and mouse-cursor freezes. I'm also using Windows 7 64-bit.
I found that switching to 256 colors in the Compatibility options addressed the graphical issue. I'm left with the mouse cursor freezing every few seconds though, which makes the game unplayable.
Alt-tabbing in out once awhile fix it for me. Tested on Vista/Win 7 32 bit though.
Thanks for the tip Ben, that seems to help. Also thanks ashx, alt tabbing didn't fix the mouse freezing sadly :(
You guys tried disabling visual themes on the game's shortcut ?
Another option for that funky colors issue might be opening the desktop properties resolution window (Right click desktop > Screen Resolution) and leaving that window open while playing the game.
Same problem here. I use Vista though
Just in case anyone is having this problem or the same problem with a different game, you should check out this page:
[url=]http://www.age-of-empires.net/gameforum/Blah.pl?v-print/m-1273316507/[/url]

Click the "Download Palette Stealer Suspender" This program works great!
Post edited April 19, 2011 by Ethaar
avatar
Namur: You guys tried disabling visual themes on the game's shortcut ?

Another option for that funky colors issue might be opening the desktop properties resolution window (Right click desktop > Screen Resolution) and leaving that window open while playing the game.
Holy freaking crap, this combined with visual themes off and 256 color works...so far. Weird

Edit: Well it works, the colors are still kinda crap but playable. Still not happy about my purchase so far.
Post edited February 08, 2011 by doggyhatefire
WORKS! very strange...


Having the screen resolution open does solve the mouse issue...very very strange but glad to see the game working...
avatar
Namur: You guys tried disabling visual themes on the game's shortcut ?

Another option for that funky colors issue might be opening the desktop properties resolution window (Right click desktop > Screen Resolution) and leaving that window open while playing the game.
WOW - thanks for the tip - this solved my cursor issue - just great Namur - I miised this game so much
avatar
dave1moira: WOW - thanks for the tip - this solved my cursor issue - just great Namur - I miised this game so much
You're welcome. Have fun ;)
Mine resolution still looks like crap. Windows XP SP3 - Dell Laptop, Intel integrated graphics.

Any other thoughts?
I turned off "visual themes" by right clicking the shortcut and I also ran it in Windows XP mode and it fixed all of my issues. The cursor issue was the big problem for me. I am using Windows 7 64 bit on a lenovo laptop.

I did not have to leave the screen resolution open. I tried that and it did not work for me.

Hope this helps anyone still having this issue.

I still do wish that it would work natively in Windows 7 as I doubt the next version of Windows will have it.
If u still have freeze problems try this, it works very well on older games. I am running XP. Go to the Dx Diagnostic Tool Dialog box, Display tab and disable the DDraw Acceleration. It is quick and easy to swap back and forth from old to new games this way. I put a quick link to it on my taskbar too.
Im running windows seven and I can't seem to find a way to see the game on the whole screen no matter how i adjust the resolution of the display ..it's just a little square in the middle...u can see the units and scroll but there's no way you can enjoy the game...I would appreciate some help..thank you