It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi fellow gog members,
When I start a game of PG 2 many items on the map contain these multi colored pixels, is there some setting I can adjust to fix this?
I'm running Windows 7 64 bit, and as of the moment, using the on board graphics built into the motherboard. The on board graphics is a NVIDIA GeForce 6150SE nForce 430.
It also seems that my mouse freezes about half of the time when I get to the select campaign/scenario screen as well.
I see that a lot of gog games seem to be having trouble with Windows 7 :(
Thank you goggers!
This question / problem has been solved by damnitdanielimage
finally got this game to work with only one problem. the screen is overblown like a balloon. is there any way to shrink the screen display down?
Check out the GOG solution.

http://www.panzercentral.com/forum/viewtopic.php?f=22&t=38679&p=659905#p659905
avatar
damnitdaniel: Just in case anyone is having this problem or the same problem with a different game, you should
check out this page:
[url=]http://www.age-of-empires.net/gameforum/Blah.pl?v-print/m-1273316507/[/url]
Click the "Download Palette Stealer Suspender" This program works great!
Excellent! That worked for me! Here is a new link to the program: http://blog.macuyiko.com/p/palettestealersuspender.html
I would never had purchased this game had I known all the problems I would have. First, as others have indicated, it plays in very funky colors and my mouse constantly turns off. I have tried the suggested fixes, no good. If this is what I can expect from gog.com, then this is my last purchase!
Hi .I am having a issue with the game resolution.It is always in fullscreen mode,I was looking for a way to reduce the window size somewhat.And I also heard there was to be a patch update for pzgen2???
The version with community patches (PG2UK220.EXE) e.g. increases the maximum numbers allowed in scenarios.

There is a tool to run it in windowed mode.
avatar
damnitdaniel: Hi fellow gog members,

When I start a game of PG 2 many items on the map contain these multi colored pixels, is there some setting I can adjust to fix this?

I'm running Windows 7 64 bit, and as of the moment, using the on board graphics built into the motherboard. The on board graphics is a NVIDIA GeForce 6150SE nForce 430.

It also seems that my mouse freezes about half of the time when I get to the select campaign/scenario screen as well.

I see that a lot of gog games seem to be having trouble with Windows 7 :(

Thank you goggers!
avatar
BenRichardson: Hi Daniel,

I experience the precise same symptoms - discolored graphics and mouse-cursor freezes. I'm also using Windows 7 64-bit.

I found that switching to 256 colors in the Compatibility options addressed the graphical issue. I'm left with the mouse cursor freezing every few seconds though, which makes the game unplayable.
Hi,
Has this issue been solved yet? Here I am, 5 years after this post, experiencing the same problem. It says solved on the bottom of the screen, but what is the actual solution? When I click the this was solved by link, the link on that post just brings this page back up.
Post edited June 18, 2015 by richken
avatar
alexhulpe: Im running windows seven and I can't seem to find a way to see the game on the whole screen no matter how i adjust the resolution of the display ..it's just a little square in the middle...u can see the units and scroll but there's no way you can enjoy the game...I would appreciate some help..thank you
that is windowed mode,How did you do that?
I want to record my gameplay.need exact step by step ,not maybe or i think guesses.thanks.
avatar
The-Business: The version with community patches (PG2UK220.EXE) e.g. increases the maximum numbers allowed in scenarios.

There is a tool to run it in windowed mode.
is it the tool I have? d3Dwindower?or not?
and how do i use it?I have added the panzer gen exe file to the list to run it and when I click the arrow button,down below it says I need to run in admin,I don't know how to do that in the D3Dwindower.....
Post edited March 17, 2016 by me-262-schwalbe
1. Launch D3DWindower-English.exe
2. Press the "+" button.
3. Select the PG2UK220.EXE from the Panzer General 2 directory.
4. Select the item in the list and click the Settings button (second button from the right).
5. Width and Height are labeled wrong, you have to put the desired width into the "Height" field and the height into "Width". For this example, I use 800 and 600 as values.
6. In the DLL input, select the D3dHook.dll which comes packed with D2DWindower.
7. In the Window Mode tab, uncheck "DirectX 1-6" and "Use GDI".
8. Click on "Run Program" (third button from the right).
avatar
BenRichardson: Hi Daniel,

I experience the precise same symptoms - discolored graphics and mouse-cursor freezes. I'm also using Windows 7 64-bit.

I found that switching to 256 colors in the Compatibility options addressed the graphical issue. I'm left with the mouse cursor freezing every few seconds though, which makes the game unplayable.
avatar
richken: Hi,
Has this issue been solved yet? Here I am, 5 years after this post, experiencing the same problem. It says solved on the bottom of the screen, but what is the actual solution? When I click the this was solved by link, the link on that post just brings this page back up.
I'm having the exact same problem. Windows 7 64 Bit, with the discoloured graphics and the mouse freezing problem. Is there a clear solution for this problem?
PalettestealerSuspender - updated link
Having the same problem...tried DLing the PaletteStealer and my browser said it was a malicious website.
avatar
Namur: You guys tried disabling visual themes on the game's shortcut ?

Another option for that funky colors issue might be opening the desktop properties resolution window (Right click desktop > Screen Resolution) and leaving that window open while playing the game.
This tip worked perfectly (Win 7 64bits). Thank you!