It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Narf_the_Mouse: @Henkkles: Odd, but that last line about NWN1 using only 0.7% CPU tells me your problem is probably, and unfortunately, entirely different. :(

So my solution won't work for you; or, rather, if it did, you've still got a much bigger one.

Try running CPU-z, and see if your CPU is running at around or over full speed when NWN1 is running. If it's at a downclocked speed (mine idles around 850 MHz if there's little to do) then... I don't actually know, but it would be another data point.

Hopefully someone else will know more. :/

Edit: Had another thought. Check to see if your anti-virus/malware scanner is running high at the same time? Persistently and repeatedly scanning mwmain.exe could have that result. And check for anything else using CPU at the same time in general - Might get some info out of that.
The multipliers are jumping between 8-32 simply because my full CPU utilization is around 7% when NWN is running. My virus software is Avira which shouldn't have problems like that. Like I said, my CPU is not being throttled as it's being utilized 5-7% total while I'm running NWN, which would mean that for some reason my processor can't seem to be able to allocate resources to running the NWN engine.

I've tried fiddling with affinity and resources but to no avail so far. My CPU is a hyper-threaded dual core, which might be the root of the issue. However my system is a Thinkpad and I don't think the OEM BIOS has a switch to enable/disable HT.
Narf_the_Mouse: Steps so far:

1) Compatibility:
1a) WinXP Service Pack 2 mode - Seemed to make a big difference
1b) Administrative mode
1c) Disable full-screen optimizations - Seemed to make it closer to a reasonable frame rate
1d) Set High DPI Scaling to System (Enhanced) - Unsure if there's a difference; at the least, did not hurt
2) Install latest NVIDIA drivers
3) Intel's driver update utility just cycled through "download -> install -> ask for restart -> download -> ...", so was not useful in my case, unfortunately.
4) NVIDIA control panel:
4a) Set high-performance mode for nwmain.exe - No apparent difference, but it might help someone else.
4b) Set OpenGL graphics to use graphics card for nwmain.exe - No apparent difference, but it might help someone else.
5) Disable GeForce Experience In-Game Overlay - This seemed to make some noticeable difference
6) It may also help to turn off Windows 10's Game Bar, but mine was already off.

At this point, my frame rate is acceptable. The test scene is my wizard, panther familiar, Tomi Undergallows, and a Summon Monster II (boar) at the gates of the Peninsula District during the prison outbreak in OC1.

Also, if you want to play on Windows XP, I would recommend against buying a laptop. Instead, buy VMWare Workstation Player. Or use the free version.
Henkkles: 1a) done
1b) done
1c) ?
1d) ?
2) -
3) no updates
4) -
5) -
6) done

No effect whatsoever.

Narf_the_Mouse: New post, because > 5 min, I guess. Also, want to make sure people see this.

As per this thread:

1) Set "Client CPU Affinity=-2" in nwnplayer.ini
2) Set sound to use "Miles Fast 2D Positional Audio" in the advanced sound settings

With all changes, game now plays smoothly, with no apparent lag.
Henkkles: 1) done
2) done

No apparent effect.

When I opened task manager, I noticed that Neverwinter Nights was not using more than 0.7% of the processor, but fiddling with affinity and the like only made it crash.
1c) Disable Full Screen -- means run it in full screen but the suggestion is to remove optimisations for that mode. I think nwn runs better full-screen instead of windowed, but I do not recall full-screen optimisation options.
1d) This means to set windows screen fonts to a particular value. I can suggest setting them to their default size.
2) Is this because you are running an ATI Radeon card? If so, make sure to use a set that is compatible with nwn. My nwn had a bit of fiddling to do to find an ATI Radeon driver that worked well. Once I found it, I cut it to dvd, next to my nwn saves and files. (btw, Nvidia drivers are also sensitive. You might need to google around to find out which drivers people are using). I found that using the basic ATI Radeon driver without all the fancy bells and whistles ATI can force upon you, worked best,
3) Since Nvidia and ATI drivers are sensitive, I suspect Intel drivers will also be sensitive. Need a bit of fiddling around with here. Intel drivers came out 10 years after nwn.
4) I found using basic video drivers, without installing all the additional junk, was best.
5) (see 4)
6) I do not know what the game bar is.

Just so you know, I struggled with nwn when it was new. My experience was atypical. Other people had less trouble. But once I had it installed, I made sure to save and try to remember every procedure and file I used with the install. NWN was that powerful and appealing to me. I still have all the files from 10+ years ago.

I tend to find debugging is a process of elimination. Im not great at it. But i had to isolate every element and test it one by one. Someone mentioned they had installed Avira? Uninstall or disable it.
1c) Runs in borderless full window. This might help; or might hinder. It will also probably make NWN less likely to crash if you alt-tab out; probably, quite a bit less likely.
1d) This: suggests it is a bit more complex than that, but also that it probably won't help.
6) It's analogous to Steam overlay, or Geforce overlay, only from Microsoft. For more info, I suggest Google, as I have not sought further info since turning it off.

Overall, I can't say all of what I did was necessary or helpful, which is why I marked the ones that seemed to have an effect. Critique like yours is helpful, to help narrow down the actually useful ones. :)