It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I'm about 800 turns into the game and for some reason some techs are no longer completing.. for example the Titan starship. It got down to 1 turn left to discover and.. stopped there. it's been there for about 40 turns now. Other techs as well seem to get down to 1 turn, then sit there for forever and a day and then just random appear in prototype phase,last there for 10+ turns, and then finally unlock, but titan has been sitting at 1 turn to discover forever.

I have both techs at the required level, it's just not completing. Anyone know what would cause this?

I'mn not using any mods or anything of the sort, just the straight up version you get from GoG, windows 7.
Sounds like the "StuckTech" problem.

The game got a number of issues that was never addressed by the game developer. Fortunately most of those got fixed by dedicated players. Bhruic have made a lot of small patches that fixes many issues, and it comes neatly whit it's own patcher.

You need the patcher itself, and then any of the fixes / patches you want. Just follow the instructions on the site. Find it here
.lcs-hamburg.de/Bhruic/bhruic.dyndns.org/patcher/patcher.php.htm ( put www in front )
avatar
Naia000: You need the patcher itself, and then any of the fixes / patches you want. Just follow the instructions on the site. Find it here
.lcs-hamburg.de/Bhruic/bhruic.dyndns.org/patcher/patcher.php.htm ( put www in front )
a real link is easier ...
http://www.lcs-hamburg.de/Bhruic/bhruic.dyndns.org/patcher/index.php.htm
Post edited June 09, 2017 by Rocco.40
Yeah but I don't post here very often, so haven't got enough forum reputation to post links.

Thanks for helping out though.
avatar
Naia000: Yeah but I don't post here very often, so haven't got enough forum reputation to post links.

Thanks for helping out though.
no prob.
apparently you need some 20 reps before you can post hyperlinks-
https://www.gog.com/forum/general/you_cannot_post_any_links_at_this_moment