It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've installed the game to my notebook from the original CD, but the problem is the same, it is unplayable, the framerate is very bad.
Is someone here who has the Steam version? Is it unplayable too on Intel integrated graphics?
Slay: No matter what visual settings I select, the game is in slow motion. The frag rate is at minimum. I can't even get past the opening sequence as it stutters alot. The sound stutters aswell.

Also, if I try to start a multiplayer game, it seems to work well, I can move around normally, although when I try to fire a weapon there seems to be some stutter and some small lag time.

I tried playing around with the visual settings & sound settings quite alot but the end result is the same. The opening sequence stutters and can't even get the game started.

Thanks for any input you may have. I run the game on a Compaq nx7300 with Vista sp1, Intel Core Duo CPU T2450 @ 2.00 GHz , 1 Gig Ram, Mobile Intel 945 Express Chipset Family 256 RAM.

Could it possibly be the video card? Although I would highly doubt it. Also sent in a support e-mail, figured people on these boards amight also have some insight.
I had a same problem with you. I have an Intel GMA 4500 onboard graphic card on my laptop. I tried to use 3dfx emulation program for making KP work in 3dfx mode. There were many 3dfx emulations and I tried to use 'GlideWrapper084c' which is one of them for 3dfx mode.
Fortunately it worked well even better than any other options which were mentioned in here.
However only the one problem is that it's a little bit dark even though I put the brightness bar at the end of the right side in game option. I mean I can't make it brighter.
But it work well. Why don't you try it? Also if you find the way to make it brighter then let me know it. :)

You can find 'GlideWrapper084c' in a below link.
Post edited May 30, 2011 by simpson0116
I'm running on Seven 64 Home, and forcing the game in 256 and disabling visual themes did the trick, no need for win98 compatibility (although it can't hurt), thanks for your help everyone.
Post edited August 06, 2011 by Megacyclo
hunvagy: Hello there, I too had problems with the lags in gameplay, os I tried some of the suggestions. I have a laptop with and Intel GMA 950 and XP. What worked is setting the compatibility mode to 256 colors, Win98 mode and disabling visual themes. This way, I could even play at resolutions up to 1024x768 without any problems. I hope this helps someone in need :)
That totally worked for me. Thanks!
I have an intel HD2000 onboard video chip, and onboard audio. What I did was create my own shortcut on the desktop to kingpin.exe, not even using the gogwrap thing. I then went into the capatability tab and checked "run as administrator", "disable visual themes", and "run this program in capatability mode for Windows XP service pack 3". The intro had a bit of a stutter but the game itself runs fine.