It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
high rated
I've read that many people struggle with the "application error 0xc0000022" problem at Icewind Dale 2 startup.

Here is a fix what worked for me:
1. Open Control Panel
2. Open Programs and Features
3. Choose "Turn Windows Features on or off"
4. Check Legacy Components and DirectPlay
Finally dug up this 3 year old post, and it fixed the problem I've been messing with for like an hour.

Thanks much!
low rated
avatar
SwordSaint7: Finally dug up this 3 year old post, and it fixed the problem I've been messing with for like an hour.

Thanks much!
For the future, *don't* necro 3 year old threads just to say "me too". Sheesh!
avatar
a_kapanen: I've read that many people struggle with the "application error 0xc0000022" problem at Icewind Dale 2 startup.

Here is a fix what worked for me:
1. Open Control Panel
2. Open Programs and Features
3. Choose "Turn Windows Features on or off"
4. Check Legacy Components and DirectPlay
Same issue with LOMSE, this worked!
low rated
avatar
a_kapanen: I've read that many people struggle with the "application error 0xc0000022" problem at Icewind Dale 2 startup.

Here is a fix what worked for me:
1. Open Control Panel
2. Open Programs and Features
3. Choose "Turn Windows Features on or off"
4. Check Legacy Components and DirectPlay
avatar
MagusGhost: Same issue with LOMSE, this worked!
"For the future, *don't* necro 3 year old threads just to say "me too". Sheesh!"

Damn, some people are just mindless.
This Hickory dude is bitter AF
avatar
Realentropy: This Hickory dude is bitter AF
Like I said in the post above...
Me too
I have this same issue with Win10. This solution doesn't appear to exist for win 10. any ideas?
avatar
tkvasager: I have this same issue with Win10. This solution doesn't appear to exist for win 10. any ideas?
Still works, they've just moved a few things around. Start > Settings > Apps > Programs and Features > Turn Windows Features On or Off > Legacy Components > Direct Play.
Post edited December 02, 2017 by Ryan333
avatar
a_kapanen: I've read that many people struggle with the "application error 0xc0000022" problem at Icewind Dale 2 startup.

Here is a fix what worked for me:
1. Open Control Panel
2. Open Programs and Features
3. Choose "Turn Windows Features on or off"
4. Check Legacy Components and DirectPlay
Thanks! :-)
avatar
a_kapanen: I've read that many people struggle with the "application error 0xc0000022" problem at Icewind Dale 2 startup.

Here is a fix what worked for me:
1. Open Control Panel
2. Open Programs and Features
3. Choose "Turn Windows Features on or off"
4. Check Legacy Components and DirectPlay
Much appreciated man!