It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hey everyone, I'm trying to play DH on Windows 10. I can run the game in full screen, however the screen is flickering and it's unbearable.

The suggested fix on the net is to run the game windowed and in 16 bit color.
However, on Win 10 you can no longer set the desktop to 16 bit color, and if the desktop isn't 16 bit color, the game launcher won't allow you to select "windowed" (WTF?!)

I tried using 16 bit color depth in the compatibility options, but it still flickers. I also tried to edit the config file to force window mode and then set the config file read-only, however that crashes the game on launch.

I'm using the latest NVIDIA drivers.

Any ideas?

EDIT: I used the NVIDIA control panel's program-specific settings to disable all anti-aliasing options and enable v-sync, which improved the issue, though it's not completely gone yet.
Post edited July 31, 2018 by FLX83
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
FLX83: Any ideas?

EDIT: I used the NVIDIA control panel's program-specific settings to disable all anti-aliasing options and enable v-sync, which improved the issue, though it's not completely gone yet.
Hello !
Well, I don't know if it could help you -and I'm on Windows 7-, but I noticed that softwares running in background may interfere, especially "dynamic" ones (something which updates visually for example).
In my case, I'm using a software called Fences to sort the icons on my desktop... with it running, lot of flickering/blinking (for HoI 2 & EU 2). Turned off, no more blinking. Only one software running in the background can be the problem ;)

I got the info and found the issue thanks to Spinorial in this thread :
https://www.gog.com/forum/europa_universalis_series/screen_flickering

By the way, I just found this wiki too :
https://hoi2.paradoxwikis.com/Technical_issues#Screen_Flicker

Hope this will helps you :)
Post edited February 25, 2019 by Splatsch
If you have an NVidia-Card, you can try to disable FXAA in Driver Settings. Worked for me on Win 8.1 64 bit.