}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
high rated
Since many players these days have widescreen monitors i thought i'd share my experiences so far playing gothic games in widescreen resolutions. Since i have a 16:10 monitor, this is the only widescreen aspect ratio i can be certain of, but i imagine things are similar if you have a 16:9 monitor.
Gothic

The game seems to support widescreen resolutions just fine, the problem is you can not set higher resolutions in the game options. The maximum resolution i could set was 1400x1050 and the only widescreen resolution that i could see in the options menu for my aspect ratio was 1280x800. The solution to get the game running in 1680x1050 resolution for example is to edit gothic.ini and change the following values:
zVidResFullscreenX=640
zVidResFullscreenY=480
zVidResFullscreenBPP=16
to
zVidResFullscreenX=1680
zVidResFullscreenY=1050
zVidResFullscreenBPP=32
There is a problem with that solution however. If you run the game after changing these values the game starts and displays the resolution fine but if you exit the game the resolution gets set back to 640x480x16. The solution for me was to:
1) tweak the gothic.ini file,
2) make a copy of the gothic.ini file and rename it to for example gothic.in
3) create a gothic.bat file in the folder with gothic.exe, gothic.ini and our new gothic.in containing the following:
copy gothic.in gothic.ini /Y
gothic.exe
exit

That makes sure gothic.ini file that the game messes up gets replaced with our tweaked ini file every time the game is started with that .bat file. Voila! Permanent 1680x1050 resolution! I have tried making gothic.ini read only after tweaking but that just makes the game crash. I'm sure there are more elegant solutions, but for me this one works just fine.
Gothic 2
I imagine that the solution that i used with Gothic works here too, but this time the game can actually see and set the higher resolutions too. The only thing you need to do for it is to open gothic.ini and change:
extendedMenu=0
to
extendedMenu=1
After that you should see more resolutions in the game video settings.
Now for the bad news. The game seems to have an annoying bug with widescreen resolutions. Everything gets stretched so that people look fat etc. The cure is to talk to any npc. After you do everything looks normal until you load a savegame. Strangely Gothic does not seem to have that bug.
Post edited February 17, 2009 by tolknaz
Have you tried marking gothic.ini as read-only? I haven't tried it, but it shouldn't cause any problems unless you try to change settings from within the game. That would certainly be easier than your batch file solution.
Thanks for the tip, got 1920x1080 (16:9) running just fine.
avatar
Arkose: Have you tried marking gothic.ini as read-only? I haven't tried it, but it shouldn't cause any problems unless you try to change settings from within the game. That would certainly be easier than your batch file solution.

He said:
avatar
tolknaz: I have tried making gothic.ini read only after tweaking but that just makes the game crash. I'm sure there are more elegant solutions, but for me this one works just fine.
May i add that downloading the aspect ratio/camera fix for gothic 2 found in the link below
makes things look much better.
http://forum.worldofplayers.de/forum/showthread.php?t=441131
When you're running widescreen resolutions in Gothic 2 you only see about half of your character from about the torse and up. This fix makes it so the camera acts normally in all resolutions as well as fixes the aspect ratio so you can see more around you.
Post edited February 28, 2009 by Hammerfall
Hey guys i tryied it on my laptop and gothic used all the available resolutions by default (including widescreen), so i don't knowif gog patched it or sg but it was fine for me by default.
Is it actual widescreen or just stretched?
Here you can find way much better solution for Gothic I:
http://www.widescreengamingforum.com/wiki/index.php/Gothic
http://www.widescreengamingforum.com/wiki/index.php/Gothic_II
I've got Gothic 2 running at 1280x800 just fine on my laptop, no tweaking required.
Where is the Gothic 2 Gold edition config file locted. In Gothic 2 it was located in the System folder. This is my first GOG game installation so I am not sure if their version hides or changes the directory structures.
I have no way of changing the resolution.
edi: I found it. The game installs to 2 seperate folders in program files. Oh and since this was my first post, hello everyone.
Post edited June 27, 2009 by saguy
avatar
RadicalTed: Is it actual widescreen or just stretched?

It is actual widescreen.
This fix is a godsend, thanks tons. :)
PS. the WSGF one doesnt appear to work on GOG version.
And for those like me that didn't know how to create a .bat file (shameful, I'm sure :P), here's how:
Open notepad, paste in appropriate text, save as .bat file/all file types.
Lastly pointing the Gothic shortcut to "C:\Program Files\GOG.com\Gothic\system\gothic.bat" will ensure maximum joy but I guess that was assumed by most.
Looks lovely in 1680x1050! :)
Post edited October 07, 2009 by chautemoc

That method works fine for Gothic 2 (but not for 1).
I just wanted to add that according to the Widescreen Gaming Forums, the widescreen resolutions for both Gothic I and II are VERT-, meaning you lose some of the vertical view that you would have if you were using a 4:3 resolution. Therefore, some players may wish to stick to letterboxed 4:3 if they are picky (like me). This will run the game in 4:3 with black bars on the side if you are using a widescreen monitor.
Letterboxing to 4:3 can be done via a general option that can be set for most video cards, preserving the aspect ratio of any program that is run on the machine. Usually found under "scaling" options. Unfortunately my current card doesn't support this so I can't test it with Gothic specifically but it should work.
Awesome thread. Let me add two things. (in short, I recommend the cam patch linked above.)

avatar
Waltorious: I just wanted to add that according to the Widescreen Gaming Forums, the widescreen resolutions for both Gothic I and II are VERT-
1. Actually, Gothic 2 is described as STRETCHED, not vert -, but I think you're sort of right. Read on.

2. The real story for Gothic 2 is more complicated than that. I can't totally figure it out--I think that the vanilla game will show vert- and/or aspect ratio distortions at the same time, depending on god knows what. On my computer, it actually used vert- in all resolutions, and PINCHED the 4:3 resolutions (skinny mode), instead of stretching the 16:10. You can tell if your screen is being pinched/stretched by finding a square object on the ground, and rotating your camera around to see how (if) it distorts and becomes elongated.

I used a few pieces of the ironkeep community patch 2.10 (I don't recommend the full installer), and I think I now have proper FOV in a 1280x800 resolution. The camera goes down to my character's ankles instead of his thighs. It's weird, the 4:3 resolutions still get pinched. Also, it stretches when you first load it, but as soon as you talk to an NPC, it fixes itself. Here's how you can replicate this, if you're interested.

a. download the rar from post 69 in this thread http://forum.worldofplayers.de/forum/showthread.php?t=848246&page=4
b. back up your "GOG.com\Gothic 2 Gold\_work" folder
c. copy and replace the files from the "_work" folder in the rar ONLY. The other folders contain an old german .exe, some experimental dlls, and a texture pack.
d. resume game.
Post edited March 07, 2011 by fjdgshdkeavd
Thanks fjdgshdkeavd! It finally looks like right aspect ratio.