It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Une conférence ./play.it est au programme de la prochaine Ubuntu Party, qui aura lieu le week-end des 20-21 mai à Paris, à la Cité des Sciences et de l’Industrie.
Venez nombreux, ce sera l’occasion idéale d’en apprendre plus sur le fonctionnement du projet et influer ses développements futurs ;)
La conférence ./play.it à l’Ubuntu Party aura lieu dimanche 21 mai à 14h.
Une annonce très spéciale aujourd’hui : la version 2 de ./play.it est sortie !

La nouveauté majeure de cette version est le support d’un nouveau format de paquet : les .pkg.tar utilisés par Arch Linux et ses dérivées.
./play.it n’est donc plus réservé aux utilisateurs de distributions basées sur Debian ;)
On doit le support de ces nouvelles distribution essentiellement à Amadren, qui a écrit les premiers prototypes de scripts fonctionnant sur Arch Linux, et Mopi qui a écrit un nombre impressionnant de scripts ./play.it 2 pour qu’on puisse aujourd’hui proposer une bibliothèque très respectable de jeux installables sur Arch Linux via ./play.it

Le format des scripts a aussi été retravaillé avec dans l’idée de les rendre plus facile à modifier, voire d’en créer de nouveaux, sans aucune connaissance en programmation requise.

Et pour les développeurs curieux, la bibliothèque a été entièrement ré-écrite avec encore une fois l’objectif de la rendre plus facile à comprendre et modifier.
Pour rappel, le code du projet est hébergé sur plusieurs forges git publiques :
./play.it sur git.debian-fr.xyz
./play.it sur framagit
./play.it sur github.com

À partir de maintenant, tous les nouveaux scripts publiés seront écrits dans ce nouveau format, et supporteront donc les distributions basées sur Arch Linux en plus de celles basées sur Debian.

Allez, je me doute que ce qui vous intéresse vraiment c’est la liste des jeux gérés par ./play.it 2, alors la voici :

140
Afterlife
Aladdin
Anachronox
Anna’s Quest
Aquaria
The Elder Scrolls: Arena
Ascendant
Baldur’s Gate - Enhanced Edition
Baldur’s Gate 2 - Enhanced Edition
Bastion
Battle Worlds: Kronos
Beatbuddy: Tale of the Guardians
Bio Menace
Botanicula
Braid
Braveland
Braveland Wizard
Braveland Pirate
Caesar III
Crypt Of The Necrodancer
Darkest Dungeon
Dark Reign 2
Darwinia
Day of the Tentacle Remastered
Deponia
Deponia 2 - Chaos on Deponia
Desperados: Wanted Dead or Alive
Don’t Starve
Dust: An Elysian Tale
Edna & Harvey: Harvey’s New Eyes
else Heart.Break()
Emperor: Rise of the Middle Kingdom
English Country Tune
Faster Than Light
Fez
Gnomoria
GreedCorp
Heroes of Might and Magic III
Heroes of Might and Magic IV
Heroes of Might and Magic V
HuniePop
The Even More Incredible Machine
Infinium Strike
Kingdom Rush
Legend of Grimrock
Lovers in a Dangerous Spacetime
MouseCraft
Never Alone
No Pineapple Left Behind
Octodad Dadliest Catch
Pillars of Eternity
Pirates Gold
Race The Sun
Regency Solitaire
Runner2: Future Legend of Rhythm Alien
Shadowrun: Dragonfall
Skullgirls
Softporn Adventure
Sunless Sea
The Jungle Book
The Lion King
Theme Hospital
The Settlers II
The Swapper
The Witcher 2: Assassins Of Kings
The Elder Scrolls II: Daggerfall
Torin’s Passage
Torment: Tides of Numenera
Transistor
Trine
Undertale
War§ow
Windward
World of Goo
Zork I: The Great Underground Empire
Zork II: The Wizard of Frobozz
Zork III: The Dungeon Master
Beyond Zork: The Coconut of Quendor

À vos jeux ;)
Salut à tous !

Je suis en train d’améliorer le système d’auto-détection de la distrib en train de tourner utilisé par ./play.it (pour choisir le format de paquet le plus approprié par défaut).

Pour ça, j’apprécierai d’avoir le retour des trois commandes suivantes sur différentes distributions, merci à ceux qui voudront bien me donner un coup de main en partageant ça ici :
grep '^ID=' '/etc/os-release' | cut --delimiter='=' --fields=2
head --lines=1 '/etc/issue' | cut --delimiter=' ' --fields=1 | tr [:upper:] [:lower:]
lsb_release --id --short | tr [:upper:] [:lower:]
Pensez bien à préciser depuis quelle distribution vous lancez ces commandes ;)
Bonjour,

Commandes lancées depuis Ubuntu 14.04 LTS :

$ grep '^ID=' '/etc/os-release' | cut --delimiter='=' --fields=2
ubuntu

$ head --lines=1 '/etc/issue' | cut --delimiter=' ' --fields=1 | tr [:upper:] [:lower:]
ubuntu

$ lsb_release --id --short | tr [:upper:] [:lower:]
ubuntu
Merci ;)
Salut,

Depuis une Archlinux (installée avec Architect), les trois commande me renvoient "arch".
avatar
tatapoum: (…)
Merci ;)

J’ai réussi à avoir pas mal de tests via différents forum, je pense que j’ai maintenant un système de détection plutôt fiable.

Pour les curieux, on peut y jeter un œil par ici :
https://git.debian-fr.xyz/vv222/play.it/src/21c798cc70b08e8b17b2af3462cbf8e5cb4b69e1/play.it-2/src/30_init.sh
(lignes 90 à 128)
La version 2.0.1 de ./play.it vient d’être publiée, avec pas mal de changements au menu…

Les changements impactant la bibliothèque, ayant donc un effet sur tous les scripts :

2.0.1

  * Teste la conformité des options données via la ligne de commande
    suffisamment tôt pour arrêter le script avant que des opérations
    potentiellement longues aient lieu

  * Afficher "OK" lorsqu’une tâche potentiellement longue sans retour visuel sur
    sa progression prend fin

  * Si l’auto-détection du système hôte échoue, affiche un avertissement avant
    de choisir le format par défaut

  * Sur toutes les distributions fournissant apt >= 1.1, les instructions
    d’installation affichés utilisent apt au lieu de dpkg + apt-get
 
Les scripts gérant de nouveaux installeurs :
140
Aquaria
Baldur’s Gate - Enhanced Edition
Braid
Crypt Of The NecroDancer
Darkest Dungeon
Pillars of Eternity
Skullgirls
Windward

Les scripts suivants ont vu une amélioration de la gestion de la dépendance à WINE sur les systèmes basés sur Debian :
Anachronox
Caesar III
Dark Reign 2
Desperados: Wanted Dead or Alive
Emperor: Rise of the Middle Kingdom
Heroes of Might and Magic III
Heroes of Might and Magic IV
Heroes of Might and Magic V

Et il reste encore quelques mises-à-jour :
Botanicula
  Ajout d’une dépendance manquante sur libxml2
Caesar III
  Lancement du jeu dans un bureau virtuel WINE pour éviter des soucis d’affichages sur certains écrans larges
Crypt Of The NecroDancer
  Réduction de la liste de dépendances
  Gestion d’un pack d’icônes optionnel fournissant l’icône originale du jeu
Darkest Dungeon
  Ajout de fichiers journaux persistants

Une poignée de jeux ont été portés de ./play.it 1 à ./play.it 2, ce qui apporte entre autres la possibilité de construire des paquets pour Arch Linux pour les jeux suivants :
Beyond Good and Evil
Grim Fandango Remastered
Jazzpunk
Pirates!
Psychonauts
The Dark Eye: Chains of Satinav

On termine par ce que vous attendez certainement avec le plus d’impatience, les nouveaux jeux gérés par ./play.it :
A Boy and His Blob
Beholder
Dark Echo
Deponia 3: Goodbye Deponia
Fotonica
Fran Bow
Hatoful Boyfriend
Haven Moon
Jotun
Journey of a Roach
Kentucky Route Zero
Lumini
Neon Drive
Nihilumbra
Ori and the Blind Forest
Out There: Ω Edition
Particulars
Sentris
The Book of Unwritten Tales
The Dark Eye: Memoria
The Night of the Rabbit
The Stanley Parable
The Whispered World
TRI: Of Friendship and Madness
War for the Overworld
Whispering Willows
Ziggurat

À vos jeux ;)
Oui, c'est une belle initiative mais les portages sont rarement à la hauteur de la version Windows, du coup, mieux vaut passer par Wine même chez les indépendants, une bien meilleure stabilité et parfois plus de contenus.
Au moins, sous Wine, pas de problème de dépendance, de version à respecter ou autre, c'est moins prise de tête et plus portable. C'était sympa dans les années 2000 de résoudre les problèmes de dépendances mais avec la tonne de jeu porté sous GNU/Linux, ma patience et mon intérêt pour la résolution de dépendance pour jouer à une version inférieur sont loin, très loin.

EDIT: Quoi qu'il en soit, bel effort.
Post edited July 11, 2017 by Adrien2002
avatar
Adrien2002: les portages sont rarement à la hauteur de la version Windows, du coup, mieux vaut passer par Wine même chez les indépendants, une bien meilleure stabilité et parfois plus de contenus.
Pour les jeux proposé avec un client natif officiel et pour Windows (avec une compatibilité parfaite avec WINE), j’ai le parti pris de toujours choisir la version Linux. Mais rien n’empêche d’écrire des scripts pour les versions Windows aussi.

D’ailleurs, le script pour Planescape: Torment gère indifféremment des installeurs pour Windows et pour Linux (dans tous les cas le jeu tourne avec WINE).

avatar
Adrien2002: C'était sympa dans les années 2000 de résoudre les problèmes de dépendances mais avec la tonne de jeu porté sous GNU/Linux, ma patience et mon intérêt pour la résolution de dépendance pour jouer à une version inférieur sont loin, très loin.
Ça tombe bien, avec ./play.it la gestion des dépendances est automatisée !

avatar
Adrien2002: Quoi qu'il en soit, bel effort.
Merci ;)
Post edited July 11, 2017 by vv221
Plus raisonnable que la dernière mise-à-jour, la version 2.0.2 est arrivée !

Quelques correctifs au menu :
2.0.2

  * Correction d’un bug lors de la copie du binaire du jeu vers le préfixe
    du jeu pour certains jeux natifs

  * Contournement du bug WINE 29661 présent sur les version de WINE antérieures
    à la version 1.9.20
Différents jeux ont de nouveaux installeurs de gérés, et des améliorations pour tourner sur une plus grande variété de configurations :

 • Botanicula
    Ajout de l’option '-nodebug', réduit les risques d’un crash aléatoire au lancement avec le pilote graphique intel
    Ajout d’une dépendance sur libasound_module_conf_pulse, pour s’assurer que le son fonctionne sur les systèmes utilisant PulseAudio

 • Darkest Dungeon
    Nouveaux installeurs GOG gérés
    Correction du système de logs persistants

 • Hatoful Boyfriend
    Ajout d’une dépendance sur wqy-microhei.ttc pour corriger un problème de textes manquants

 • Jotun
    Nouvel installeur GOG géré
    Ajout d’une dépendance sur pulseaudio

Et bien sûr, cette mise-à-jour s’accompagne de nouveaux jeux :

 • Anomaly 2
 • Darkest Dungeon: The Crimson Court
 • Knights of Pen and Paper
 • Osmos
 • Stacking

À vos jeux ;)
Ça faisait un (long) moment qu’on me le demandait régulièrement, c’est maintenant fait : ./play.it accepte les donations !

Vous pouvez donc soutenir l’équipe de ./play.it sur Liberapay, un site de micro-dons réguliers anonymes :
https://liberapay.com/play.it/

Si jamais vous avez déjà contribué à ./play.it, faites-moi signe et je vous expliquerai comment rejoindre l’équipe sur Liberapay. Vous pouvez rejoindre l’équipe sans pour autant être obligés de prendre une part dans les donations si vous le souhaitez.

Au passage Liberapay est intégralement libre, et son code source est hébergé sur GitHub :
https://github.com/liberapay/liberapay.com
La version 2.1 de ./play.it est sortie il y a quelques jours, avec quelques changements intéressants au programme ;)

Commençons par les changements concernant la bibliothèque et tous les jeux gérés par le projet :
2.1.0

  * Première version de ./play.it pleinement installable

  * Nouveau script 'play.it' chargeant automatiquement le script approprié
    pour l’archive donnée en argument

  * Affichage d’une erreur en cas d’appel du script avec un argument non géré

  * Nouvelle fonction facilitant la mise en place d’icône via la génération de
    liens post-installation

  * Nouveau type d’application permettant de lancer un jeu natif sans passer
    par un préfixe ./play.it

  * La bibliothèque peut être chargée sans exécuter les actions spécifiques aux
    scripts ./play.it, facilitant sa ré-utilisation par d’autres projets
 
Quelques scripts existants ont vu passer des mises-à-jour :

 • 140
   Nouvel installeur Humble
 • Chaos Reborn
   Nouveaux installeurs GOG
 • Jazzpunk
   Pack d’icônes
 • Jotun
   Nouvel installeur GOG
 • War for the Overworld
   Nouvel installeur GOG

Et comme toujours, qui dit nouvelle version dit nouveaux jeux :

 • Anima: Gate of Memories
 • Hollow Knight
 • Icewind Dale - Enhanced Edition
 • J.U.L.I.A Among the Stars
 • Melody’s Escape
 • Reus
 • Shadowrun: Hong Kong
 • Solar 2
 • Startopia
 • The Blackwell Epiphany
Post edited August 24, 2017 by vv221
La version 2.1.1 de ./play.it est sortie il y a qelques jours, elle apporte surtout des correctifs et des améliorations de la syntaxe des scripts.

Le journal des modifications :
2.1.1

  * Meilleure gestion des erreurs lors de l’utilisation de organize_data()

  * Correction du comportement de postinst_icons_linking() pour qu’il nécrase
    pas le contenu pré-existant des scripts de post-installation/pré-suppression

  * Correction d’une mauvaise utilisation de wrestool où une option spécifique à
    une icône était utilisée lors de tous les appels suivants à wrestool
 
En réalité, plus de 70 scripts ont été modifiés lors de la préparation de cette mise-à-jour, mais seuls ces changements sont intéressants pour un utilisateur du projet :

 • Crypt of the NecroDancer
   Nouveaux installeurs GOG gérés
 • Neon Drive
   Nouvel installeur Humble géré

Et bien sûr, quelques nouveaux jeux rejoignent le catalogue :

 • A Story About My Uncle
 • Anomaly Defenders
 • Arcanum: Of Steamworks and Magick Obscura
 • Baldur's Gate
 • Baldur's Gate II
 • Candle
 • Heroes Chronicles
 • Heroes of Might and Magic V - Tribes of the East
 • Invisible Inc.
 • The Longest Journey
 • To The Moon
 • Torchlight
 • Tropico

Pour ceux que vous avez déjà vu sur le site de ./play.it, il s’agit d’une ré-écriture pour les baser sur ./play.it 2 et leur apporter entre autre la possibilité de construire des paquets pour Arch Linux.

À vos jeux !
Post edited September 23, 2017 by vv221