It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
All this time later I realized that I dun derped ... from the initial steps in the first post about keeping the 1.2 on I focused purely on the Galaxy folder in the Program Files, not the ProgramData folder and here I was wondering why it was still prompting me at random intervals to update it. Just nuked all the relevant files in there and bam no update reminder since the start of this current session.

I noticed due to the fact that some of the icons (even in the Program Files folders) were the new icon of the 2.0 yet I am running 1.2 .. few searches later found what I missed.

Cancer removed~
avatar
Knightspace: Oh yes yes, i did just that, but a few days ago it just updated itself without me even touching the launcher.
Do you have the option "Test upcoming features in GOG Galaxy public betas" unchecked in "Settings\General"?
avatar
Knightspace: Oh yes yes, i did just that, but a few days ago it just updated itself without me even touching the launcher.
avatar
Beelzebuch: Do you have the option "Test upcoming features in GOG Galaxy public betas" unchecked in "Settings\General"?
Yes, it was just a weird event apparently. Old launcher works for me still, at least for now.
Hi, I have the same probelm as everyone here: I have W7, no intentions to upgrade to W10 and the only option now is to intall Galaxy 2.0 that requires W8 at least. Do you have any solution for this?
avatar
BinarySunset77: Hi, I have the same probelm as everyone here: I have W7, no intentions to upgrade to W10 and the only option now is to intall Galaxy 2.0 that requires W8 at least. Do you have any solution for this?
Best solution to that is to not install 2.0 lol. Windows 7 is good and has so much better compatibility with older stuff so I dont think you should ever even remotely consider changing it to 8, I have Window 10 on the PC and 7 on the Laptop so best of both worlds ^_^

The 1.2.67.58 setup file in the first post still works fine then if you follow all the steps outlined in the same post there shouldn't be any issues. I personally made the mistake of missing a few files to delete from the comp post-install but using a shortcut to the Galaxy.exe with the extra parameters has seen it run fine. Even on my Windows 7 Laptop same thing no issues.