It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello,

I have a clean installation of GOG Galaxy on my Mac laptop. When I start Galaxy I get a window with the message 'The application "GalaxyClient.app" can't be opened.' See attachment

Even so, Galaxy starts and after a little while it crashes.

I have tried deleting GalaxyClient.app along with the /Users/Shared/GOG.com/Galaxy folder and reinstalling, but the result is the same.

Is there a fix for this?

macOS Sierra 10.12.5
GOG Galaxy 1.2.9

Thanks,
Janus
Attachments:
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
januschr: Hello,

I have a clean installation of GOG Galaxy on my Mac laptop. When I start Galaxy I get a window with the message 'The application "GalaxyClient.app" can't be opened.' See attachment

Even so, Galaxy starts and after a little while it crashes.

I have tried deleting GalaxyClient.app along with the /Users/Shared/GOG.com/Galaxy folder and reinstalling, but the result is the same.

Is there a fix for this?

macOS Sierra 10.12.5
GOG Galaxy 1.2.9

Thanks,
Janus
Could you verify that the main executable located under GalaxyClient.app/Contents/MacOS/GalaxyClient has an executable flag (+x)? You can check that by opening Terminal app and typing:

cd /Applications/GalaxyClient.app/Contents/MacOS/
ls -la

The second command should display something like this:
drwxrwxrwx 3 fallen admin 102 May 24 09:57 .
drwxrwxrwx 9 fallen admin 306 May 24 09:57 ..
-rwxrwxrwx 1 fallen admin 17063424 May 24 09:57 GalaxyClient

Could you print that output for me? Thank you!
avatar
Fallen_Zen: Could you verify that the main executable located under GalaxyClient.app/Contents/MacOS/GalaxyClient has an executable flag (+x)? You can check that by opening Terminal app and typing:

cd /Applications/GalaxyClient.app/Contents/MacOS/
ls -la

The second command should display something like this:
drwxrwxrwx 3 fallen admin 102 May 24 09:57 .
drwxrwxrwx 9 fallen admin 306 May 24 09:57 ..
-rwxrwxrwx 1 fallen admin 17063424 May 24 09:57 GalaxyClient

Could you print that output for me? Thank you!
Hi,

Thank you for your response. The executable flag is set:

drwxrwxrwx 3 janus admin 102B May 22 19:19 ./
drwxrwxrwx 9 janus admin 306B May 22 19:19 ../
-rwxrwxrwx 1 janus admin 16M May 22 19:19 GalaxyClient*
I've got a similar issue on my MacBook, here is the output from the terminal

2017-06-01 13:47:35.333 [Error][Comm Service Reconnect (25)]: Unable to connect to Communication Service: Error Message: Failed to reconnect to Communication Service after 10 attempts with reconnect interval 1000ms.
Stack Trace
2 GalaxyClient 0x000000010e2dbc98 _ZN6galaxy27service_message_interchange9internals21CommServiceConnection25reconnectWithManyAttemptsEhNSt3__16c hrono8durationIxNS3_5ratioILl1ELl1000EEEEE + 904
3 GalaxyClient 0x000000010e2e041d _ZN4Poco6Thread15FunctorRunnableIZN6galaxy27service_message_interchange9internals21CommServiceConnection20star tReconnectThreadEvE4$_15E3runEv + 29
4 libPocoFoundation.42.dylib 0x0000000114cbd000 _ZN4Poco10ThreadImpl13runnableEntryEPv + 176
5 libsystem_pthread.dylib 0x00007fffe76e29af _pthread_body + 180
6 libsystem_pthread.dylib 0x00007fffe76e28fb _pthread_body + 0
7 libsystem_pthread.dylib 0x00007fffe76e2101 thread_start + 13
Post edited June 01, 2017 by g3o
avatar
januschr: Hi,

Thank you for your response. The executable flag is set:

drwxrwxrwx 3 janus admin 102B May 22 19:19 ./
drwxrwxrwx 9 janus admin 306B May 22 19:19 ../
-rwxrwxrwx 1 janus admin 16M May 22 19:19 GalaxyClient*
Ok, what output you get from this command?

codesign -vvvv /Applications/GalaxyClient.app

Also what happens when you run the client from the Terminal?
cd /Applications/GalaxyClient.app/Contents/MacOS/
./GalaxyClient

Sorry for the delayed response.
Okay, looks like after I restarted my laptop the client works without any problem!
Thanks Fallen_Zen for your help!
avatar
Fallen_Zen: Ok, what output you get from this command?

codesign -vvvv /Applications/GalaxyClient.app
Here is the output:
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/libpcre.dylib
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/libpcre.dylib
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/libexpat.dylib
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/libexpat.dylib
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/libcrypto.1.0.0.dylib
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/libcrypto.1.0.0.dylib
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/GalaxyClient Helper NP.app
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/GalaxyClient Helper NP.app
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoCrypto.42.dylib
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoCrypto.42.dylib
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/GOG Galaxy Protocol Helper.app
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/GOG Galaxy Protocol Helper.app
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/GalaxyClient Helper.app
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/GalaxyClient Helper.app
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/GalaxyClient Helper EH.app
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/GalaxyClient Helper EH.app
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/Chromium Embedded Framework.framework
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/Chromium Embedded Framework.framework
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoDataSQLite.42.dylib
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoDataSQLite.42.dylib
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoJSON.42.dylib
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoJSON.42.dylib
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoData.42.dylib
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoData.42.dylib
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoFoundation.42.dylib
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoFoundation.42.dylib
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoNetSSL.42.dylib--prepared:/Applications/G alaxyClient.app/Contents/Frameworks/libPocoNet.42.dylib
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoNetSSL.42.dylib--validated:/Applications /GalaxyClient.app/Contents/Frameworks/libPocoNet.42.dylib
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoUtil.42.dylib
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoUtil.42.dylib
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoXML.42.dylib
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoXML.42.dylib
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoZip.42.dylib
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/libPocoZip.42.dylib
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/libz.1.2.8.dylib
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/libz.1.2.8.dylib
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/libsqlite.3.10.2.dylib
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/libsqlite.3.10.2.dylib
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/libssl.1.0.0.dylib
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/libssl.1.0.0.dylib
--prepared:/Applications/GalaxyClient.app/Contents/Frameworks/QtCore.framework
--validated:/Applications/GalaxyClient.app/Contents/Frameworks/QtCore.framework
/Applications/GalaxyClient.app: valid on disk
/Applications/GalaxyClient.app: satisfies its Designated Requirement
avatar
Fallen_Zen: Also what happens when you run the client from the Terminal?
cd /Applications/GalaxyClient.app/Contents/MacOS/
./GalaxyClient

Sorry for the delayed response.
A bunch of stuff gets written to the Terminal and after 10 retries it fails with the message below,

It looks like the same error that g3o gets, but in my case rebooting does not help.

Thank you.

2017-06-01 21:22:42.527 [Error][Comm Service Reconnect (26)]: Unable to connect to Communication Service: Error Message: Failed to reconnect to Communication Service after 10 attempts with reconnect interval 1000ms.
Stack Trace
2 GalaxyClient 0x0000000101bd1c98 _ZN6galaxy27service_message_interchange9internals21CommServiceConnection25reconnectWithManyAttemptsEhNSt3__16c hrono8durationIxNS3_5ratioILl1ELl1000EEEEE + 904
3 GalaxyClient 0x0000000101bd641d _ZN4Poco6Thread15FunctorRunnableIZN6galaxy27service_message_interchange9internals21CommServiceConnection20star tReconnectThreadEvE4$_15E3runEv + 29
4 libPocoFoundation.42.dylib 0x00000001085af000 _ZN4Poco10ThreadImpl13runnableEntryEPv + 176
5 libsystem_pthread.dylib 0x00007fffc0dbb93b _pthread_body + 180
6 libsystem_pthread.dylib 0x00007fffc0dbb887 _pthread_body + 0
7 libsystem_pthread.dylib 0x00007fffc0dbb08d thread_start + 13
-----

2017-06-01 21:22:42.536 [Fatal][Comm Service Reconnect (26)]: GOG Galaxy encountered a fatal error: unknown exception
Logger Exception: System exception(cannot lock mutex), code 0
Logger Exception: System exception(cannot lock mutex), code 0
Post edited June 09, 2017 by januschr
Hello,

Any news on this?

Thank you
avatar
januschr: Hello,

Any news on this?

Thank you
Hello,

Are you using any 3rd party firewall or antivirus software? Seems client has problems connecting to communication service. Could you create an issue on mantis and attach logs from /Users/Shared/GOG.com/Galaxy/Logs? Also any crash reports from any GOG Galaxy process would be helpful (you can find those in Console app, user reports section).
Post edited July 04, 2017 by Fallen_Zen
Please pardon the thread necromancy, but I also just spent a couple night troubleshooting this very same issue.

After running via the CLI, I discovered that ~/Library/App Support/GOG.com was owned by root and not my user. Fixing that permissions issue solved this problem for me.
avatar
deisum42: Please pardon the thread necromancy, but I also just spent a couple night troubleshooting this very same issue.

After running via the CLI, I discovered that ~/Library/App Support/GOG.com was owned by root and not my user. Fixing that permissions issue solved this problem for me.
That did it for me as Well!!!! TOPP!!!!
Thx alot!
looks like here all ppl are the pro hackers that can find and fix permissions and it's grate! but can you make help for noobs lake me?))