It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I've rammed up against the 2GB limit on cloud saves so much now that the feature is more of an inconvenience than a useful feature for me personally, and I originally just wanted to disable it on Cyberpunk where it doesn't work properly at all, however it's so frustrating that I decided to just disable it globally.

The problem is that Galaxy just ignores the fact that you told it to disable Cloud Saves and keeps trying to sync anyway then saying cloud sync failed. Every time I start up Cyberpunk there is like a 1 minute delay of Galaxy trying to cloud sync even though it has been disabled.

I discovered last year that the only way to fix this, is to enable cloud saves, go into the game and manually delete save games one at a time for like 20 minutes in the slowest clunkiest user interface for this in-game ever. If you try to make it go faster by optimizing hitting the appropriate keys to delete a save, eventually you make a mistake and it loads the game, then go back into the menu, scroll to the bottom and wait 1000 years for it to display everything, then delete delete delete again. Very frustrating user interface, not user friendly.

So anyway, I did all of this and deleted so many save games that there are like 40 or so left which is way way below 2GB, however Galaxy still tries to cloud sync that and fails every single time. Sometimes for unknown reason and lately saying that the servers are busy. Doesn't buy a lot of confidence for the feature to be honest.

Anyhow, now that I deleted almost all of my save games (after making local backups on another drive instead), and it is no longer taking up 2GB of storage, it still will not sync to the cloud, and while I can disable cloud saves either just for this one game or globally in Galaxy, it absolutely refuses to stop trying to sync to the cloud.

Got me so frustrated this time around that I just want to permanently disable this broken feature and forget it ever existed. Perhaps I can have my firewall disallow traffic to the cloud storage server and return ICMP error with tcp-reset to force the client to bail trying to sync sooner or something.

Alternatively, give me the source code to Galaxy client and I will fix the problem myself...
avatar
skeletonbow: go into the game and manually delete save games one at a time
Did you try just moving all saves in the save folder to a different location for safekeeping? Very few games have any sort of index file, so going through the game interface isn't usually necessary.
avatar
skeletonbow: Sometimes for unknown reason and lately saying that the servers are busy.
Is the exact message the following?
Cloud sync is delayed due to heavy load

If so, it's what I get for all games after about a day of playing them for the first time. Though disabling cloud saves globally did make the error go away for me.

You can try testing if a fresh database makes a difference:
1. Exit GOG Galaxy if it's currently running.
2. Start File Explorer and enter the following in the address bar:
%AllUsersProfile%\GOG.com\Galaxy\
3. Move the storage folder somewhere like the desktop.
avatar
skeletonbow: Perhaps I can have my firewall disallow traffic to the cloud storage server
You can try prefixing the domain(s) with 0.0.0.0 in your HOSTS file and see if that makes it fail any faster.
Easiest way to disable cloud saves is to uninstall the galaxy client. You don't need it to access your games. Use the normal game installers from your account instead.
avatar
skeletonbow: go into the game and manually delete save games one at a time
avatar
Ice_Mage: Did you try just moving all saves in the save folder to a different location for safekeeping? Very few games have any sort of index file, so going through the game interface isn't usually necessary.
Yes, that was the first thing I tried, disabling cloud storage on the game and/or globally, exit Galaxy, going right in the directory and deleting the save game files, start galaxy, start the game, Galaxy tries to sync the game to the cloud. Right now all cloud operations are failing, however when I did this originally, even though I had deleted the files and cloud saves were disabled, Galaxy re-downloads all of the save games from the cloud.

It appears that if Galaxy has a cloud sync to perform it remembers this above all else, then whether or not cloud saves are disabled for the game or globally, when it starts up it checks to see if there were any pending failed cloud syncs, and if it does, it tries to sync them without bothering to see if cloud saves are disabled, and it will continue to do this endlessly until you get it to sync properly. It's been like this since before Cyberpunk was released in 2020, and the problem occurs with other games also so it isn't game specific.

The only way to get it to stop doing this, is to go into the game's user interface either the load game or save game screen, then manually delete savegames one at a time. How much effort that takes and how much time it takes depends entirely on the game's save game UI and how fast it processes dozens, hundreds or even thousands of save game files. In the case of Cyberpunk it used to be horribly inefficient, and took as long as 30 seconds or more to even load the thumbnails and display them. CDPR has optimized this either in 1.5 or 1.6 so it doesn't take nearly as long but it sometimes still stalls.
avatar
skeletonbow: Sometimes for unknown reason and lately saying that the servers are busy.
avatar
Ice_Mage: Is the exact message the following?
Cloud sync is delayed due to heavy load
I have seen that error a number of times lately, however the usual error I get is that it is unable to sync because my save game storage size exceeds the maximum for cloud sync. At first it was 2.1GB when the maximum is 2.0GB, but deleting 3/4 of the save game files and even checking the size of the directory was under 500MB, still caused the same error saying that my saves are 2.1+GB.

Most people are unlikely to ever encounter this I imagine because most people probably don't have hundreds of save games, so it is a problem that few people likely ever experience, and one that GOG probably doesn't test (or test well enough).
avatar
Ice_Mage: If so, it's what I get for all games after about a day of playing them for the first time. Though disabling cloud saves globally did make the error go away for me.

You can try testing if a fresh database makes a difference:
1. Exit GOG Galaxy if it's currently running.
2. Start File Explorer and enter the following in the address bar:
%AllUsersProfile%\GOG.com\Galaxy\
3. Move the storage folder somewhere like the desktop.
I've never had any problems when first playing a game. The only time I have problems is when storage space of 2GB is exceeded, upon which Galaxy just refuses to stop trying to sync even when cloud saves are disabled, specifically because a sync failed and it remembers this and forcibly tries to resync it until it gets one successful sync.

In other words, in order to successfully disable cloud sync with Galaxy, you MUST have a successful sync first as the last operation. If the last sync operation was a failure it will relentlessly try to sync every time at game start and end, and display an error. It's been this way for at least 2+ years now at least. I can't remember but it might have even been a problem back when Witcher 3 came out.
avatar
FrodoBaggins: Easiest way to disable cloud saves is to uninstall the galaxy client. You don't need it to access your games. Use the normal game installers from your account instead.
Been using GOG since 2009 so I'm well versed in installing games manually via the downloadable installer EXE files and running them directly, and I do appreciate this option to continue to exist. However, I do actually like the Galaxy client and most of its features, it makes it much easier to manage a game library of 4000+ games across about 10 platforms and be able to search the entire catalog and do other useful things that I use, like, and want. This suggestion would be throwing the baby out with the bathwater, which isn't viable to me. Thanks nonetheless for the suggestion.

I'll probably hound support about the problem soon. I just wanted to see if anyone else has had their storage exceeded, and then managed to actually get Galaxy to disable cloud saves at all, without jumping through hoops of inconvenience.

I know there are alternative solutions out there for cloud saves for games that can use arbitrary storage such as Google Drive or some other location, offering the potential to have virtually unlimited space if you control the back end. I may explore one of those solutions as Galaxy just isn't cutting it for this one single feature, while it does most other things quite well.
Post edited October 02, 2022 by skeletonbow
avatar
skeletonbow: The only way to get it to stop doing this, is to go into the game's user interface either the load game or save game screen, then manually delete savegames one at a time.
Cloud saves are synced on game start and game exit, so I can't imagine why it would matter how you delete the files. It should just be a folder that's checked for changes. I'm not saying you're wrong, mind you. I never encountered this particular situation.
avatar
skeletonbow: I do actually like the Galaxy client
You posted about GOG Galaxy in the general forum. If you don't get at least one reply telling you to uninstall it, you have just witnessed a miracle.
avatar
skeletonbow: I'll probably hound support about the problem soon.
Good luck. I imagine %AllUsersProfile%\GOG.com\Galaxy\storage\jobs.db is the specific file that stores any sort of pending file transfers. It might be something else, or the information might even be stored server-side for your account.
I've seen Galaxy sync certain games before even though they were supposed to have syncing disabled: in my case it was Dishonored 2 and Death of the Outsider.
Is galaxy sync still broken?