It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I know there have been a few threads about running Fallout and Fallout 2 in windowed mode, but how about we get one thread that gives a definitive, simple answer. So I suppose there are two questions:
1) Can it be done with the gog version?
2) If so, how? (with instructions and links if possible!)
Thanks in advance to everyone who answers!
This question / problem has been solved by geedimage
First download DxWnd from [url=][/url] (for fallout 1 and 2 you don't need the VC8SPO CTR extra).
Second extract everything in the file to a folder and then run it. Click configure and then find the fallout 1 or 2 exe.
Select the window size you want in the boxes and then tick the stretch video option, leave everything else as is. Click ok.
Now you can choose run and select the fallout exe you just configured again and it should be at whichever size you wanted in a window. You can also use the shortcut button, select the fallout exe and then name and save it to desktop for easy access.
NOTE: The videos will not work when windowed but the game runs fine and is playable. Also its not a true window, you can screen behind it but you will probably have trouble switching the mouse from game to desktop. I find you really have to throw the mouse at the side of the screen to get it out of the game. Its not a perfect solution for a window but its the best I have come across for this game so far.
sfall also supports windowed mode so you may try that out as well.
It comes with comes with unofficial patch and restoration project (however they probably do not contain latest one) or you can download and use it separately. There's a version for both FO1 and FO2.
It's pretty straightforward to use. Just extract 'ddraw.dll' and 'ddraw.ini' to fallout base directory (the one that either contains falloutw.exe or fallout2.exe) and open the ddraw.ini with any text editor. Settings are explained within.
It was buggy when I tried it a year ago with original FO2 but the have been more than 20 new versions since. I've never tried it on FO1 so I can't say how well it works on it.
edit: fixed the sfall link
Post edited February 05, 2010 by Petrell
I recommend Sfall, as it will allow you to run the game in dx9.
Is the combat and movement speed increases completey optional with that?
Ralackk: Is the combat and movement speed increases completey optional with that?
I believe so. :D
but you'll have to edit the config file.
Ralackk: Is the combat and movement speed increases completey optional with that?
Weclock: I believe so. :D
but you'll have to edit the config file.

A quick config edit isn't that bad. If sfall allows it to run in a true window then thats definatly the better option.
To use sfall, don't you have to update the version to the US version with a patch?
I had no trouble using the US version with GOG's Fallout 2.
Thank you for this, I have wanted to play Fallout 2 in windowed mode for so long now.
With sfall, the window for Fallout 1 is anchored to the upper left corner of my screen. Is this normal? Is there a setting so that I can stretch/shrink/move the window?
Thank you.
The config file for Fallout 1 should have a place to change the window size... I remember doing it, but I can't direct you specifically.
Fallout 2 is convenient because it allows you to do it in the game if you've got the latest patch.
In my opinion it would be best to install Windows 98 or ME on a virtual machine ie. M$ VirtualPC 2007 and inside the VM then install Fallout. Then the VM can be ran in window mode and the game inside can run without any problems from the underling system or hardware. As if for the performance issues, any 3 year old pc should be able to run such a configuration.
high rated
1) Fallout GOG 1 & 2 are fully compatible (with videos), they works great on my eeepc701 with winXPsp3
2) Use D3Dwindower
find it here :
( "télécharger" = "download")
"add" a game -> click on [+]
and configure it -> click on "settings":
For Fallout 2 :
height 640
width 480
use windowed mode - yes
use background priority - yes
use background resize - yes
browse and select D3dhook.dll in D3Dwindower directorie
DX1-7 - yes
DX8-9 - yes
Colour emulate -yes
Colour convert - yes
primary blt - yes
get active window - yes
get foreground (...) - yes
fixed window position - yes
cursor message - yes
cursor clip yes
set cursor pos - yes
get cursor pos - yes
For Fallout 1 :
It's the same config but try to desactivate DX1-7 and activate "DX8-9" and "use GDI"
sometimes, exactly same config as fallout 2 doesn't work
Now to launch fallout 1 or 2, launch before D3Dwindower and click on the blue arrow.
Enjoy :D
Post edited July 21, 2009 by geed
geed: Works like a charm, thanks man :)