It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Just tried playing 2.5.1 vanilla (no mods) and this is just as buggy (or even more so?) than my modded Xtra Deconstruct version. Its impossible for me to play without constantly running into some kind of bug. So the overall bugginess observed by me in this thread (and other thread/s) is not due to modding but due to simply the game being very buggy.


Edit: Also one crash and one end-turn-hang.
Post edited July 31, 2020 by Zrevnur
<GameItemType InternalName="Staff_Stag"> has a ranged melee attack. This is probably unintended.
So I suppose the big 3.0 update they promised will never come.
I was having some trouble loading save games using Xconstruct and all its compatibility patches with other mods ( such as children of the storm ) coming in from the cold.
Yes, they had to be opened from inside the game or they could not load.

When I deactivated the mods I could open the program then go to a saved game and it would open. I'll have to try it with Xconstruct only with no other mods and see if the same occurs .

( after looking over documentation for some of the other mods I think I could be looking for trouble adding them all in there )

In the vanilla game, I do notice a tendency in about 10 to 15 turns there is a frozen non-responsive screen. It may let me ctl alt del out to force quit, or it may not. If it does not force quit, I simply sign off then sign back in and then pick up from an auto save.