It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Fresh download of Diablo, error during play-diablo-1.sh step

Script error:

Extracting data from setup_diablo_1.09_hellfire_v2_(30038).exe
Error:
Available innoextract version is too old to extract data from the following archive: setup_diablo_1.09_hellfire_v2_(30038).exe

---------------------------------------

Innoextract ver:

Preparing to unpack .../innoextract_1.6-1build3_amd64.deb ...
Unpacking innoextract (1.6-1build3) ...

---------------------------------------

All up to date, new conflict?

cheers
avatar
darkneve: (…)
For the current Diablo installer from GOG, you need to have innoextract ≥ 1.8.

What is the Linux distribution you use, and its version?
avatar
darkneve: (…)
avatar
vv221: For the current Diablo installer from GOG, you need to have innoextract ≥ 1.8.

What is the Linux distribution you use, and its version?
Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic


Looking at innoextract site, 1.8 is only available for ubuntu 20.04. Wonder if it will work on my ver =)
Post edited March 04, 2020 by darkneve
avatar
darkneve: (…)
You can easily install innoextract 1.8 on Bionic by using this PPA. You can trust it, its maintainer is innoextract author.
Post edited March 05, 2020 by vv221
avatar
darkneve: (…)
avatar
vv221: You can easily install innoextract 1.8 on Bionic by using this PPA. You can trust it, its maintainer is innoextract author.
1.8 is installed, thank you much!
An update providing support for devilutionX 1.0.1 has been proposed by one of our contributors: Game update: Diablo - devilutionX 1.0.1 release

As usual, any feedback would speed up the inclusion of this update into a stable version ;)
Update

./play.it now relies on devilutionX 1.0.1 to run Diablo.