It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi there,
I recently bought Desperados, but had the same problems as many of you getting it to run properly (on Win7 64bit): constant random crashes, no matter what compatibility mode or affinity settings I applied. But as some already pointed out in the forum, it does work fine once you disable the sounds.
I did therefore take a closer look at the music and sound files themselves and saw that they are encoded using ADPCM. I already encountered problems in the past with other games that use this compression technology.
As the music and sound files in Desperados are simple WAV files, I converted them to uncompressed WAV files and the game has been running crash-free since then!
If anyone is interested how to do this (for example using the free FFMPEG converter), just drop me a note.

Post edited June 28, 2012 by NaitaOni
you sir, are my newest hero of the year. thank you a lot for this
Thank you a lot for this!

Yet, I can't understand how to use FFMPEG (I get an error concerning a "string"). I tried with another software, by simply converting the files into WAV again, but the game crashes once at the main menu.

Could you please explain how you converted / uncompressed the files?
What is the exact error message and ffmpeg command line you entered?

Anyway, here is a short tutorial on how I did it:

First of all, unpack all speech sounds if they aren't already in your version of the game.
To do so, go into your "Game\Data\" folder and rename "Sounds.pac" to "", then unpack it to the folder it is in. You should end up with a new subfolder "Sounds" containing the various speech files. You can then safely delete "" (or leave it for backup purposes).
The music files are in "Game\Data\Musics" subfolder, they should already be unpacked.

Then either put ffmpeg.exe somewhere in your path or copy it directly to the "Game\Data\Musics" folder.
Open a command prompt, change to the directory mentioned above and execute the following command:

for %i in (*.wav) do ffmpeg -y -i "%i" "%i" -ar 22050

This will convert all WAV files in that folder to uncompressed 16bit PCM and overwrite the source file.

Now repeat this process for the "Game\Data\Sounds", "Game\Data\Sounds\Expressions" and "Game\Data\Sounds\Menu" folders and you should be all done.

The error was about "stream #0.0" and an unexpected value, I can't remember the exact line.

It works with some tweaking though - actually, I got the same error with your command line too, and I finally guessed it's because FFMPEG can't convert the files in the same folder (on my PC at least). So I tried pointing to another new folder, and it worked. I used your command line to understand how to overwrite the files in 16bit PCM and keeping the same names - it was really helpful!

Then, for those who can't get this command line to work completely :

for %i in (*.wav) do ffmpeg -y -i "%i" "%i" -ar 22050

try :

for %i in (*.wav) do ffmpeg -y -i "%i" "[path to a newly created folder]\%i" -ar 22050

and repeat for each folder in "sounds" and "musics" if need be.
Post edited July 06, 2012 by Darucas
Hi there.

I am quite bad as I can't seem to get this to work and a lot of people I think will feel the same. So I have a big favor to ask. Could someone upload the uncompressed files to some file sharing site like megaupload or dropbox and share it with us? I am sure it would make a lot of people very happy!

It's me again. I wrote to with the issue and linked this page. This is the response I got:


Please disable your sound device to see if this is indeed a problem with the sound.
To do this, go to your Control Panel -> Sound, find the sound devices, right-click and select Disable (for each one, if there are many), then click OK and try playing the game.

You can re-enable all sound devices later, of course. If the devices aren't shown, right-click the white area and select "Show disabled devices" if needed.

If disabling the sound card a solution to your please convert the sound files.

To do this please download and install WinFF from here:

Start WinFF, in the "Output Details" select "Audio" as the "Convert to:", and "Wav fod CD" as the "Preset:", use the "..." button to select/create a destination folder (like: C:\Temp\Musics).

Go to the "Musics" folder in the game's directory (default: C:\Program Files (x86)\\Desperados Wanted Dead or Alive\Game\Data), select all the wav files, drag and drop them to the WinFF window, they should appear on he list, now click Convert and wait for the program to finish. You should now have the converted music files in the output folder (like: C:\Temp\Musics) you need to copy them over the old files in the game's directory (default: C:\Program Files (x86)\\Desperados Wanted Dead or Alive\Game\Data\Musics).

Now you need to do the same with the wav files in these folders:
Expressions (default: C:\Program Files (x86)\\Desperados Wanted Dead or Alive\Game\Data\Sounds)

Menu (default: C:\Program Files (x86)\\Desperados Wanted Dead or Alive\Game\Data\Sounds)

Sounds (default: C:\Program Files (x86)\\Desperados Wanted Dead or Alive\Game\Data)

Genoan Support

I tried it but it crashes right when it gets to a part that is uncompressed audio. For eg. when I uncompressed all the audio files I crashed right at the menu, when I used the original menu sounds I crashed when it loaded the map. So it doesn't work for me, but then again I have a Creative Sound card so that can be a problem. Anyone who wants to try it now has detailed instructions. For me it didn't work. :('s solution is much easier indeed, but the crash seems linked to the frequency.

As shown by NaitaOni, the files should be converted at a 22kHz frequency (it's the frequency of the original files).

So, try this:

- follow everything gog says but, before converting...
- go to "Audio" (if not displayed in WinFF, click on "Options"), then in "Frequency" enter 22050.
- now, convert!

The game should run fine afterwards!
Post edited August 03, 2012 by Darucas
I keep getting these crashes with the "motorboating" sound and huge difficulty in killing the application with ctrl+alt+del on Win7 (64-bit, on a Dell Inspiron), even after trying the solutions here, as well as various compatibility modes, installing newer soundcard drivers, etc. I refuse to try and play it with degraded sound, or no music, as this basically ruins the game!

It's disappointing that issues like this don't get fixed by the developers, since it's probably some minor bug that would take somebody a few hours to fix.

I was hoping to be able to play through the game after playing it many years ago and seeing it on special here, but no go it seems.

I even tried installing it in Windows XP mode, but that was a waste of time., please do not advertise games as being WIndows 7 compatible when so many people have been having completely crippling issues with it!
Post edited November 20, 2012 by hyperbola6
If only they would hear and read our cries for actual original fix :(
I just wanted to point people to the following thread:

ddwrapper, at least for now, seems to have fixed this issue for me.

Edit: Unfortunately, the exact same problem has now returned on higher levels. This happens even after I've converted all the WAV files to an uncompressed format. Very frustrating! It's possibly a problem in fmod.dll, a sound library that the game uses which has also been used in many other games. Using a newer version of the library might help... but I don't have such a DLL. I tried switching in fmod.dll from Robin Hood (also from GOG), but it seems like that's too new, with certain functions Desperados needs missing (possibly an interface change or something).
Post edited September 25, 2012 by hyperbola6
Now I have installed WinFF, and whenever I try to convert the files, it says "Access violation."
Now if I cannot even convert the files, what am I to do?

The game crashes. Not often, since I set compatibility mode to Win2000, yet it still does.

EDIT: It is set to WinXP SP3.

EDIT 2: I have tried converting through WINFF, I have tried the DDwrapper approach. I suspect that it is a sound file error that causes the crashes, but so far no solution seems to work. Any idea?
Post edited April 03, 2014 by iwontdance
iwontdance: Now I have installed WinFF, and whenever I try to convert the files, it says "Access violation."
Now if I cannot even convert the files, what am I to do?

The game crashes. Not often, since I set compatibility mode to Win2000, yet it still does.

EDIT: It is set to WinXP SP3.

EDIT 2: I have tried converting through WINFF, I have tried the DDwrapper approach. I suspect that it is a sound file error that causes the crashes, but so far no solution seems to work. Any idea?
Hi there. You get the error because you try to load more then 100 files. Apparently that's their limit. I have managed to convert the files, but there are 2000+..... so it was a bit of a hassle to load them all :)

I had the same issue, with the game crashing by blocking the sound into an endless tone.

I have tried all compatibility modes: win98, XP. In one of them the mouse is lagging, and in the other the crashes are still occurring.
So, I figured I'll take up on this thread an make the conversion of all the WAV files.

I have followed the steps described by JcGross in his earlier post and then taken the advice regarding the frequency modifier suggested by Darucas

The tool, WinFF is good, but it has a major draw back: you can only load 100 files at a time. So, taken into account that there were more then 2000 WAV files, it took some time to convert.

All in all, now I have a game that is crash free for more then a week now.

Thank you guys!
Post edited May 25, 2014 by bioshark
Very good workaround! Still yet the converting of the audiofiles works fine to me. But i used a easier converter, X-Media Recode. You can find it here:
No limit of files to convert make the whole thing finished quickly.

See you in the west.
did anyone have
any other solution of Desperado crashing on Win7?

did everything already: All suggested compatibility mode, converted all the sound files to uncompressed WAV, even setting the frequency of comments to zero.

the game still hangs up and crashes and the only way to recover the whole system is for me to make a hard reset. :(

such a good game... such a terrible problem.