It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi Guys,

so I've tried to play good old Commandos on my Surface 3, Windows 10 Machine. I've grabbed a Widescreen Patch for the external Monitor which kind of works, but the game has a small pause every few seconds and does not run smoothly.

Has anyone got the game to work on such a configuration?
Thanks in advance!

Eric
Same issue. Followed the instructions with the download at "kruulos.org/gaming/Commandos_BEL_BCD_Ultimate_Fixes.rar"

Game works, with resolution (windows 10) but there is a micro freeze every 10 or so seconds. Game unplayable due to inputs during freeze being ignored.
Hi there!
I used to had a freezing stuttering issue every now and then and I've tried almost every possible solution, with graphics wrappers like DJaVoodoo and such.
What I noticed however is that a freeze occurs during map scroll. Try to set the resolution to lower one like - 800x600 or even 640x480 - it's still quite playable that way. Also try to lower down the sensitivity of your mouse.
Somehow fiddling with those got me the decent performance.
When start the game awful graphic seems like 640x40 or bad graphic and look smeared.
Troubleshooting with Commandos Series on Windows 10

Commandos Behind Enemy Lines

1. Game doesn't run

- Go to game folder and rename the executable file:
commandos.exe instead of original comandos.exe

2. Stuttering Gameplay (the same works for Commandos BTCOD exe file)

- If you have Nvidia GPU, run Nvidia Control Panel / Manage 3D Settings / Program Settings
- Browse for Commandos.exe and add it to your list of programs
- Disable as many settings as you can
- Select your main GPU on "OpenGL rendering GPU" option

3. Savegames
- Use Wordpad to edit "comando.cfg" file in OUTPUT folder.
The last 3 lines must be as follow:

.SIZE [ .INITSIZE 3 ]
.PROFILE [ .USER 0 ]
.DEVELOP 1

Commandos 2 working on Win10

1. Open Settings / Apps / Apps & Features / Open Default app settings / Related Settings - Programs and Features / Turn Windows Features On or Off
2. Turn on Direct Play from Legacy Components
3. Create a direct access to Comm2.exe file, right click on it and select compatibility tab. Check the following options:
- Run compatibility mode with Windows 98/Windows ME
- Run this program as an administrator

That's the way I've managed to run it.
Post edited May 19, 2021 by kramsib
It's the mouse, somehow the mouse creates micro stutters. But no idea how to fix it. I was messing with DXwnd, but with no succes.


Also, there is no rectangle select for multiple characters.
Post edited October 26, 2021 by sektorao
avatar
sektorao: ...
I found a solution that works for me.

I'm running Win7 64 bits and the mouse stutter disappeared when using one of narzoul's old ddraw.dll replacement. Yet for some reason, this particular dll no longer exists on his github. It was from 2019, so somewhere in-between the 0.2.1 and the 0.3.0. Do not use either one, it will not work.

Since it is no longer available, I uploaded it here.

Download and unzip the ddraw.dll from this archive to the game's directory. Then it should be fine. At least, it worked for me.
Post edited January 21, 2022 by Pouyou-pouyou
Can't download that file, chrome won't let me.

In other news, i tried mousepad from a compact folding keyboard i have, and it works fine, no lag or stutter.


Edit. I checked the 0.31 version of the ddraw and it works for me.
Post edited February 02, 2022 by sektorao