It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
Haseeb_A: Thanks man , that Windower worked and graphic issues have gone :)
Please let me know if you find a way to make it full screen other than increasing desktop resolution or the hex method.
These holidays are gonna be good with Commandos :D My favorite childhood game.

PS : I use Windows 8.1
You can make it run in Fullscreen with Borderless Gaming, after you have windowed it.
Google for Borderless Gaming (BG), it is very simple...
Download BG - install BG - set compatibility mode on commandos3.exe( xp sp2, 16bit, admin) - run commandos 3 over D3D Windower(you can leave all Settings as is) - in borderless gaming set the commandos3.exe to the right side - maybe you Need to new start commandos3 - done... it's Fullscreen without graphic bugs
Post edited February 05, 2016 by thehype
That didn't work for me (Windows 10, x64, Nvidia), so I found a similar program called DXWnd.

* right click the file Commandos3.exe (e.g. in "C:\GOG Games\Commandos 3")*
* click Properties
* open the Compatibility tab
* enable the Reduced color mode with 16-bit (65536) color

* download, unpack and execute DXWnd as administrator
* click Edit --> Add
* fill Name
* as Path and Launch enter the full path of Commandos3.exe

Enter the Windows initial position & size according to what you like:
* for windowed fullscreen enter
* X: 0, Y: 0, W: 1920. H 1080 (or your screen resolution)
* select X,Y coordinates
* for a borderless window in the center of the screen:
* W: 1280. H 800 (known to be the best supported screen resolution)
* select Desktop center
* at the Input tab check Cursor Clipper --> ON to prevent the mouse cursor from leaving the game

Feel free to experiment with other settings.
https://www.gog.com/forum/commandos_series/commandos_3_unofficial_patch_for_windows_88110

Just by replacing the original EXE and add the steam_api.dll fixed the load screen and the scope glitche for me
I'm also using "dgVoodooCpl"

Hope this help someone with that problem.