It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I remember when I played this years ago that it had some great in game music, it appears to be missing. Does anyone else have this problem?
This question / problem has been solved by couggodimage
avatar
Hifihedgehog: Sorry, but mine is installed in the default GOG Games directory and it is experiencing the same issue as described above by Klesk22. I even attempted the "UseRedbookAudio=Yes" modification, which persists in userprofile.txt until the game runs and it is restored to its default value of "No". How can I get music to work again?
avatar
Goodaltgamer: after changing the file you could try to set it to read-only, hence preventing CTP to change it (again).
As already suggested by JDKC in here:

https://www.gog.com/forum/call_to_power_2/no_music_at_all_during_game/post9

Another thing: Do the people with those problems use this digital whatever it is called sound connection or a good old speaker/headphone?

redbookaudio normally refers to 16 bit, 44.1 kHz sampling, so you might want to check your sound settings IF they do allow it. I did see with other games that manually setting your sound option to those values does sometimes overcome this kind of problems.

Might also sound strange, but for those games it might be useful to have something like virtual clonedrive installed, just in case the program really wants to detect a CD as maybe your blueray or similar is not being detected and hence no sound being played.
Thank you for your help and assistance with this snarky bug. As for the first of the solutions you provided, I did already attempted changing the file attributes to "read only". As expected, the redbook audio flag does not change, but the game still has no in-game music. As for VirtualCloneDrive, I already have VirtualCloneDrive installed so that is not helping with anything. And finally, I tried changing my Surface Pro 4 to 16-bit, 44.1 KHz sampling (the default is 24-bit, 48 KHz) and the music still does not play. I am just using either the standard built-in speaker output or the headphone jack on my Surface; I am not using HDMI, DisplayPort or S/PDIF digital audio. I have many other old games from GOG (e.g. Starfleet Academy, Star Trek: 25th Anniversary, Caesar 3) and from my own library (Heroes of Might and Magic 3 with HD mod) and there are no such problems.
Post edited September 09, 2017 by Hifihedgehog
Bingo! I think I found it. The music option itself is showing itself as off in-game. I toggle it, but it remains dimmed and unselected as shown no matter what. Even though the Redbook audio setting is persisting in the user profile configuration file, the game is refusing to enable in-game music.

So how do I get around this, then?
Attachments:
Post edited September 09, 2017 by Hifihedgehog
avatar
Hifihedgehog: Bingo! I think I found it. The music option itself is showing itself as off in-game. I toggle it, but it remains dimmed and unselected as shown no matter what. Even though the Redbook audio setting is persisting in the user profile configuration file, the game is refusing to enable in-game music.

So how do I get around this, then?
I just tried on W8.1 and changing the userprofile toggles it on/off. My button is never greyed out. EDIT: Whatever option I choose for redbook.

BUT did you start via the shortcut or directly ctp2.exe (what I did)?

EDIT2: Do you guys have directplay installed?

EDIT3: It is a windows-component, so to be found under software ->Windows features -> legacy
Post edited September 09, 2017 by Goodaltgamer
avatar
Hifihedgehog: Bingo! I think I found it. The music option itself is showing itself as off in-game. I toggle it, but it remains dimmed and unselected as shown no matter what. Even though the Redbook audio setting is persisting in the user profile configuration file, the game is refusing to enable in-game music.

So how do I get around this, then?
avatar
Goodaltgamer: I just tried on W8.1 and changing the userprofile toggles it on/off. My button is never greyed out. EDIT: Whatever option I choose for redbook.

BUT did you start via the shortcut or directly ctp2.exe (what I did)?
If you are referring to the userprofile.txt file's UseRedbookAudio flag, I already changed it to "Yes" and set the file to read only. Here it is. Is there something else besides this? Yet the game still shows it grayed out. I can change the music setting temporarily to on in-game (the userprofile.txt is read-only and keeps its setting), but music is never heard and as soon as I switch back to either the menu or a playthrough or try selecting a track, the setting shows it is grayed out again.

I am running from the GOG shortcut and not directly from the executable.
Attachments:
Post edited September 09, 2017 by Hifihedgehog
avatar
Hifihedgehog: If you are referring to the userprofile.txt file's UseRedbookAudio flag, I already changed it to "Yes" and set the file to read only. Here it is. Is there something else besides this? Yet the game still shows it grayed out. I can change the music setting temporarily to on in-game (the userprofile.txt is read-only and keeps its setting), but music is never heard and as soon as I switch back to either the menu or a playthrough, the setting shows it is still grayed out as shown.

I am running from the GOG shortcut and not directly from the executable.
Sorry if you didn't see my edits ;)

Did you check for directplay?

Try with the ctp2.exe instead

And the only differences I see are the following:

ScreenResWidth=800
ScreenResHeight=600
AlienEndGame=No

ok resolution shall not matter :D
and what AlienEndGame got to say, no idea in the moment

EDIT: I just see something with on dll......if I coudl remember where I have seen here on GOG something about this......(winmm.dll)


EDIT2: found it

https://www.gog.com/forum/battle_isle/windows_10_cant_launch_the_game/post15

see if this helps......
Post edited September 09, 2017 by Goodaltgamer
I already installed DirectPlay for another game from GOG but I checked and it is still enabled.

I will try running directly from the exe and see if that works. (EDIT: No, it doesn't work.)

I tried replacing the winmm.dll file (I kept the original for safe keeping, renaming it winmm.dll.OLD) with the one from Mega at the thread you pointed to. I first tried it with its original name (sound.dll) and then I tried renaming it to winmm.dll. Both did not work.

I will also try installing it on my other PC here next to me. It is a desktop I remote into (use a headless adapter since I have no monitor) with Steam In-Home Streaming, which could very well crash or not work for this old of a game. But it could be the install is bad. (EDIT: Still working on this. Will reply in a couple minutes. EDIT2: Still no music. So it is common to both. This other system has a GTX 1080 and the intro movie sound and sound effects are working. I wonder what could be causing this?!)

I also tried disabling my anti-virus (Avast) and disabling VirtualCloneDrive. It still doesn't work. (Both are now reenabled.)
Attachments:
Post edited September 09, 2017 by Hifihedgehog