It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I remember when I played this years ago that it had some great in game music, it appears to be missing. Does anyone else have this problem?
This question / problem has been solved by couggodimage
go to options, music... there is a list of music, but it doesnt work for me too... hmmm
Same here no music either which is a bit of a pain.
high rated
avatar
aluinie: Same here no music either which is a bit of a pain.

I found the solution,
1. go to X:\Program Files\GOG.com\Call To Power 2\ctp2_program\ctp
2. open a text file named "userprofile"
3. find the line " UseRedbookAudio=No" and change it to "UseRedbookAudio=Yes"
and you should have music in your game
Post edited March 05, 2010 by Resil
thanks for solution couggod :)
Thank you Coggod for the solution. Great to have the music back.
Is it possible to get GOG.com to enable this option default upon install?
avatar
aluinie: Same here no music either which is a bit of a pain.
avatar
couggod: I found the solution,
1. go to X:\Program Files\GOG.com\Call To Power 2\ctp2_program\ctp

2. open a text file named "userprofile"

3. find the line " UseRedbookAudio=No" and change it to "UseRedbookAudio=Yes"

and you should have music in your game
Tried enabling redbook audio many times in userprofile file. Saved when i exit, and when i start the game it turns that option off again. Not sure how to fix this...
You could try setting the file to read only. I seem to not have music either and I installed the latest AE mod. I also tried Alchemy and still no music.
Post edited August 07, 2011 by JKDC
avatar
aluinie: Same here no music either which is a bit of a pain.
avatar
couggod: I found the solution,
1. go to X:\Program Files\GOG.com\Call To Power 2\ctp2_program\ctp

2. open a text file named "userprofile"

3. find the line " UseRedbookAudio=No" and change it to "UseRedbookAudio=Yes"

and you should have music in your game
Tried this; it didn't help.

(EDIT: redownloading did help, though. I'd installed it some time ago and maybe it's been patched since then.)
Post edited April 15, 2014 by furrykef
Didn't help. "Yes" after I run game changes to "No"..
This issue is not solved. I have Win 10 and no Music in game. But under Win XP in VMWare this problem does not appear.
Are people having problem with setting reversing using Windows Vista or newer, and have installed game in program files folder? Then it's probably caused by UAC as it protects program files folders from tampering. To avoid UAC interference, install games outside program files folders. (C:\GOG Games\ or something).
Post edited July 11, 2017 by Petrell
Sorry, but mine is installed in the default GOG Games directory and it is experiencing the same issue as described above by Klesk22. I even attempted the "UseRedbookAudio=Yes" modification, which persists in userprofile.txt until the game runs and it is restored to its default value of "No". How can I get music to work again?
avatar
Hifihedgehog: Sorry, but mine is installed in the default GOG Games directory and it is experiencing the same issue as described above by Klesk22. I even attempted the "UseRedbookAudio=Yes" modification, which persists in userprofile.txt until the game runs and it is restored to its default value of "No". How can I get music to work again?
after changing the file you could try to set it to read-only, hence preventing CTP to change it (again).
As already suggested by JDKC in here:

https://www.gog.com/forum/call_to_power_2/no_music_at_all_during_game/post9

Another thing: Do the people with those problems use this digital whatever it is called sound connection or a good old speaker/headphone?

redbookaudio normally refers to 16 bit, 44.1 kHz sampling, so you might want to check your sound settings IF they do allow it. I did see with other games that manually setting your sound option to those values does sometimes overcome this kind of problems.

Might also sound strange, but for those games it might be useful to have something like virtual clonedrive installed, just in case the program really wants to detect a CD as maybe your blueray or similar is not being detected and hence no sound being played.