}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I bought this game a couple of weeks ago and played it for hours with no trouble. (Love this game, one of my favs from back in the day!) However, after I installed WIN 10 the sound keeps repeating. As soon as I start a game, the music starts looping, or right clicking a building will cause that sound to loop. Its unplayable now :(

I have tried: uninstalling and reinstalling, updating all drivers, sound, video, etc, uninstalling my sound driver and reinstalling it. Running in compatibility mode, and not running in compatibility mode. I've turned off UAC with no results, and run it in administrator mode. Help please! I was about to buy the rest of the old set with pharaoh and zeus last night but I'm I'm reluctant to if WIN 10 is not going to be compatible with them.
The sound is looping on my machine as well after upgrading to Windows 10.
avatar
mclark746: The sound is looping on my machine as well after upgrading to Windows 10.
I really wish i had waited to upgrade!

I tried everything on this list that support sent me to no avail:

1) Please make sure that yo u use "Run as Administrator" to install and to start the game (right-click on the shortcut or setup file and select "Run as Administrator").

2) Please reinstall the game AND add it to your anti-virus/firewall software's exception/trusted list. Simply disabling firewall or AV software could not be enough, since some of those software's are running still in background or in services list.

3) Reinstall the June 2010 DirectX runtime package, then use the DirectX web installer.

You can find the archive file containing the 2010 package installation files here:
http://www.microsoft.com/en-us/download/details.aspx?id=8109

You will have to extract the files into some folder, then open that folder and launch the DXSETUP.exe file in order to proceed with the installation.

Afterwards, download the latest DirectX web installer and use it as well:
http://www.microsoft.com/en-us/download/details.aspx?id=35

4) AMD recently provided hotfix for their drivers. Please update your graphics device drivers:
http://support.amd.com/en-us/download

5) Please reinstall Visual C++ 2013 SP1 Redistributable Packages:
https://www.microsoft.com/en-us/download/details.aspx?id=40784
after pressing Download select:
vcredist_x64.exe
vcredist_x86.exe

6) Maybe you have some settings forced on your graphics device in Catalyst Control Center. If so then try to reset them:
I) Right-click on your desktop and select Catalyst Control Center.
II) In the upper-right corner of the window, select Preferences.
III) Select Restore Factory Defaults.

7) Please open the Control Panel (you can do it by using WinKey+X key combination) go to Programs > Programs and Features, click the Turn Windows features on or off link, find the Legacy components on the list, enable DirectPlay and click OK to install it.

none of that worked. The best 'fix' i can come up with for now to make it playable is turn music off, and when one of the city sounds starts looping, right click an engineer's post since it has a 'silent' city sound. Its playable then until win 10 comes out with a patch or a true fix is found. I want to get Pharaoh and Zeus as well but not if it has this same bug. Do you have these games? Are they doing the same thing?
Post edited August 14, 2015 by kelisw
** UPDATE **

Even though I thought I had gotten the sound problem to go away (and it did for a pretty long time), it reared its ugly head again. If you get a fix from support that works, I'd love to know.
Post edited August 16, 2015 by mclark746
avatar
mclark746: Anyway, I'm just a customer like you, so this isn't an official solution but maybe it'll help. As for the other games you mentioned, I haven't played them so I'm not sure if they'll have problems too. I'm kind of like you with Windows 10, though. I kind of wish I'd waited a bit longer to upgrade so some of the bugs could be worked through.
These forums are primarily run by the community, with GOG.com staff around, but hardly ever providing support (except for new releases). Any posts here answering problems are usually community solutions, as it's usually the community who has to support the older games.
This almost seems to easy to be true but I just fixed the sound repeat issue on win 10 by setting the compatibility mode to win 7 and baaaam. sounds as it should be...
avatar
ben.gengenbach: This almost seems to easy to be true but I just fixed the sound repeat issue on win 10 by setting the compatibility mode to win 7 and baaaam. sounds as it should be...
Hope so. Things seemed to be going pretty good for me until I ended up with one of the desert-type cities (ok...so not really a desert, but with light brown ground instead of green). Everything was fine until a fire happened, and that seemed to retrigger the sound issue. If I exited and then re-opened it, the sound worked fine until another fire or disease broke out. So, I still think there's some Win 10 compatibility issue outstanding, but I guess at least the game is still playable.
avatar
mclark746: The sound is looping on my machine as well after upgrading to Windows 10.
avatar
kelisw: I really wish i had waited to upgrade!

I tried everything on this list that support sent me to no avail:

1) Please make sure that yo u use "Run as Administrator" to install and to start the game (right-click on the shortcut or setup file and select "Run as Administrator").

2) Please reinstall the game AND add it to your anti-virus/firewall software's exception/trusted list. Simply disabling firewall or AV software could not be enough, since some of those software's are running still in background or in services list.

3) Reinstall the June 2010 DirectX runtime package, then use the DirectX web installer.

You can find the archive file containing the 2010 package installation files here:
http://www.microsoft.com/en-us/download/details.aspx?id=8109

You will have to extract the files into some folder, then open that folder and launch the DXSETUP.exe file in order to proceed with the installation.

Afterwards, download the latest DirectX web installer and use it as well:
http://www.microsoft.com/en-us/download/details.aspx?id=35

4) AMD recently provided hotfix for their drivers. Please update your graphics device drivers:
http://support.amd.com/en-us/download

5) Please reinstall Visual C++ 2013 SP1 Redistributable Packages:
https://www.microsoft.com/en-us/download/details.aspx?id=40784
after pressing Download select:
vcredist_x64.exe
vcredist_x86.exe

6) Maybe you have some settings forced on your graphics device in Catalyst Control Center. If so then try to reset them:
I) Right-click on your desktop and select Catalyst Control Center.
II) In the upper-right corner of the window, select Preferences.
III) Select Restore Factory Defaults.

7) Please open the Control Panel (you can do it by using WinKey+X key combination) go to Programs > Programs and Features, click the Turn Windows features on or off link, find the Legacy components on the list, enable DirectPlay and click OK to install it.

none of that worked. The best 'fix' i can come up with for now to make it playable is turn music off, and when one of the city sounds starts looping, right click an engineer's post since it has a 'silent' city sound. Its playable then until win 10 comes out with a patch or a true fix is found. I want to get Pharaoh and Zeus as well but not if it has this same bug. Do you have these games? Are they doing the same thing?
I too have this problem with Caesar III. Both Pharaoh and Zeus are absolutely fine for me however.
I'm having a similar issue, though it's also happening with the music.

It was weird...I was playing for about 2 hours with no issues and it all of a sudden started.

Closing and reopening the game doesn't help. I tried running it in Windows 7 Compat. Mode as well.


UPDATE:

The problem seems to fix itself by running it in Windows Vista compat. mode (and ONLY Windows Vista) for some reason. At least it seems so, so far. I'd need to play it again for about a 3 hour stretch to truly see if it works or not.
Post edited August 29, 2015 by deadalewives
avatar
ben.gengenbach: This almost seems to easy to be true but I just fixed the sound repeat issue on win 10 by setting the compatibility mode to win 7 and baaaam. sounds as it should be...
Danke Ben! It worked for me, at least now ;)
The compatibility mode only seems to be working for one map. After that it starts looping again :(
Is there no other fix?
high rated
avatar
varengas: The compatibility mode only seems to be working for one map. After that it starts looping again :(
Is there no other fix?
IndirectSound is worth a try:
http://www.indirectsound.com/
avatar
varengas: The compatibility mode only seems to be working for one map. After that it starts looping again :(
Is there no other fix?
avatar
ZellSF: IndirectSound is worth a try:
http://www.indirectsound.com/
Seems like this solved the problem for me. Thanks!
hey,
i tried to play c3 on win 10 and had big problems to play with the resolution 1920x1080.exe, because there are heavy sound problems. When you play the game, the sound loops every 5 seconds. After hours of trial and error i solved the problem with a virtualmachine win 7 in Vmware (the only programm that support native resolution). there you can go with full hd (or other resolutions that you can find here) and play with no sound issue´s^^
avatar
ZellSF: IndirectSound is worth a try:
http://www.indirectsound.com/
avatar
aytekaman: Seems like this solved the problem for me. Thanks!
YES! This was the fix I was looking for! :D