It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I cannot save in BS1, when I press the save button the game just crashes to desktop. From what I can tell no save file is created, I haven't found any at least. The game also crashes to desktop if I press the restore button.

Things I've tried so far is reinstalling in another directory and running the game as admin, but none of that made any difference.

I'm using Windows 7 x64. I don't know what other information might be useful for this game.

Any help is greatly appreciated!
This question / problem has been solved by Namurimage
avatar
Kefaz: I cannot save in BS1, when I press the save button the game just crashes to desktop. From what I can tell no save file is created, I haven't found any at least. The game also crashes to desktop if I press the restore button.

Things I've tried so far is reinstalling in another directory and running the game as admin, but none of that made any difference.

I'm using Windows 7 x64. I don't know what other information might be useful for this game.

Any help is greatly appreciated!
I'm also using Windows 7 x64 and am having the same issue.
Have the same problem on vista.
high rated
Yep, i got the same thing but luckily it was easy to fix

-i created a folder on C:\ called SAVES
-i edited the sword1.ini file and pointed the save path to the folder i created, meaning i changed the savepath to

C:\SAVES

It's saving fine now. I'm guessing the problem relates to the path to the game folder being too long when it comes to creating a save file.
Post edited January 12, 2011 by Namur
Thanks! That worked perfectly.
You're welcome ;)
avatar
Namur: Yep, i got the same thing but luckily it was easy to fix

-i created a folder on C:\ called SAVES
-i edited the sword1.ini file and pointed the save path to the folder i created, meaning i changed the savepath to

C:\SAVES

It's saving fine now. I'm guessing the problem relates to the path to the game folder being too long when it comes to creating a save file.
Thanks for the pointer. Rather than create a new folder, I enclosed the savepath in quotes, which also did the trick. i.e. for my setup I changed it to:

savepath="D:\Games\Broken Sword - The Shadow of the Templars\"

Richard
avatar
richardhunt500: Thanks for the pointer. Rather than create a new folder, I enclosed the savepath in quotes, which also did the trick. i.e. for my setup I changed it to:

savepath="D:\Games\Broken Sword - The Shadow of the Templars\"

Richard
No problem, good to know you got it working as well ;)
Numur, unfortunately, I'm not very computer savvy. How do I find the sword1.ini file? I don't see it in the game file location.
avatar
irondog: Numur, unfortunately, I'm not very computer savvy. How do I find the sword1.ini file? I don't see it in the game file location.
The sword1.ini should be inside the game folder.

If you installed the game to the default location it should be :

C:\Program Files \GOG.com\Broken Sword - The Shadow of the Templars

or

C:\Program Files (x86) \GOG.com\Broken Sword - The Shadow of the Templars
Post edited January 12, 2011 by Namur
I just loaded the files into ScummVM and it saves and loads fine.
I had forgotten how to do things with really old games. I just had to make a separate folder in which the saved files will go, and change the .ini savefile to that folder´s name. Didn´t work for me to just add quotes, but using a separate folder did it.
Hey guys,

how exactly did you go about saving the .ini file? I just tried the two suggestions here and I still couldn't get it to work. Could you give a step-by-step breakdown for those of us who are unlucky?

GREATLY appreciated; I would really love to be playing this again. :)

EDIT: Never mind, just forgot to run the program "As Administrator." haha
Post edited January 14, 2011 by FireFox516
avatar
Namur: Yep, i got the same thing but luckily it was easy to fix

-i created a folder on C:\ called SAVES
-i edited the sword1.ini file and pointed the save path to the folder i created, meaning i changed the savepath to

C:\SAVES

It's saving fine now. I'm guessing the problem relates to the path to the game folder being too long when it comes to creating a save file.
It works. Thank you.
avatar
texis: It works. Thank you.
You're welcome ;)