It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
It seems that a few people have had graphical issues with BS:TAoD on newer systems. I'm trying to run it on a Lenovo IdeaPad 310-15ISK (this is my first post so I can't post a link to the specs, sorry), drivers freshly updated; it's not a top-notch gaming powerhouse but it runs older (Grim Fandango) and newer (Beyond Eyes, Bastion) non-intense 3D games very well, and therefore I would expect the specs to be more than sufficient for BS4.

At whatever graphics settings, the in-game animation is incredibly jerky (the opening video cutscene runs fine) - not just a slight drop in frame rate, but a constant lag that looks less than 6 fps (I don't know the exact frame-rate, but it is unusably low). I'm not having the blacked-out 'silhouette' character problems mentioned in other forums.

I've tried running the game in compatibility mode, and tried enabling multicore processing in custom.ini, neither of which have made a difference. (I'm posting this query here because I bought the game as a digital download through GOG, so I believe it doesn't require the disc-version-specific patch.)

Anybody else encountered and/or solved this problem with the game? Any suggestions would be most welcome!
Post edited February 02, 2017 by pygmyking
No posts in this topic were marked as the solution yet. If you can help, add your reply
Seems you've already tried the most logical solutions. Disabling anti-aliasing and/or forcing a single core setting affinity in task manager are the only other solutions that come to mind.
avatar
dr.schliemann: Disabling anti-aliasing and/or forcing a single core setting affinity in task manager are the only other solutions that come to mind.
Thanks for the tips, I'll give them a try!
Unfortunately neither worked. I didn't know about setting processor affinity before, so that might come in useful sometime! Thanks again.

I sent an email to Revolution Software's support inbox - hopefully I'll receive a response sometime.
avatar
pygmyking: Unfortunately neither worked. I didn't know about setting processor affinity before, so that might come in useful sometime! Thanks again.

I sent an email to Revolution Software's support inbox - hopefully I'll receive a response sometime.
I was having problems replaying BS4 in windows 10 so I changed this and it worked
in the bs4 main folder under system
in the custom file I changed the 0 to 1 -
[EmThreadManager]
m_uiUseExtraProcessors = 1

also in compat - m_bForceVSyncOn = 1

I mainly had the video scenes running in slow motion and it now works normally
not sure if the thread manager fixed it or both changes.
Having the same problems;

The intiial cutscene is fine. When it switches to George running, it slows to a crawl.

Edit: I've tried the core changes, V-Sync and so on but no dice, stutters around at crawl. Running it on a GTX 970 rig so bugger knows what I can do next.
Post edited April 06, 2017 by RVallant
Surely someone has fixed this? Steam and GOG both sell it yet plenty of complaints. Some get it working, some don't. I don't understand this.

EDIT - Ok I am very confused. I tried every single suggestion regarding compatibility modes, affinity, etc and nothing helped. One guy mentioned having to restart so on a whim I did that. Now it's working fine?

I guess windows 10 is doing something it doesn't like regarding the video drivers. A fresh reboot seems to be the answer.
Post edited August 23, 2017 by avatar_58