It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Links: I actually don't know if the -no3d still does what it is supposed to for the HiRes patched version of arcanum.exe. It accepts it without complaining, but in my opinion it is very probable that it does nothing.
Palora: It seems that way, it was certinly not helping with my issue.
Doesn't that mean " -doublebuffer" also does nothing?
I'm not using anything in my shortcut and it is working well but almost all of the old posts make mention of both -no3d and - -doublebuffer.
Not necessarily, but if you need to use double buffering, I'd try with the HiRes installation instead of the switch. Just in case :P

By the way, it is enabled by the HiRes patch by default, so unless you changed it in config.ini, it should already be using them.
I see. Thanks for the help and the info, working perfect.
No problem. Enjoy!
Just bought the game and I) can't seem to get it to work, I can't make it full screen, so i tried windowed works ok until i start the game after the character creation window, when every bit of text over laps and its a constant black screen. I followed these instructions 3-5 times with clean installs each time and i just dont seem to be able to get it to work for me at all.

I'm sure the og version is great but i want to play with hd res.

Can someone please help
SkinnyHD: (...)
I'm sure with some troubleshooting we could get things working, but I recommend you start over from scratch with a new installation and use the new 1.5.1 UAP only:
thank you very much
Worked perfectly. Arcanum is running as smooth as butter.
Links: If all else fails, try rendering by software, by changing the "Renderer = 1" option in the HiRes patch config.ini file to "Renderer = 0", and running _install.bat again
This finally did the trick for me. Thanks!

With all the fixes and wrappers I've stacked on top of one another by now, I was starting to find new and exciting problems (like rectangular fragments of the loading screen showing in place of character shadows) on top of the base ones
I have tried everything and when I did all of the things mentioned above I get that buggy screen when it starts with green and when I get to the menu splits the screen to blue and black. Can somebody help please?
Tried everything hoping it would fix my problem but I seem to have a problem that no one else has since I looked everywhere and no hint of this issue has appeared anywhere for some reason after watching the intro I seem to be stuck in an empty part of the map with a naked shopkeeper and a chest
PandaManJB: Good evening,

I have followed all the instructions and the game seems to run quite smoothly but I'm not satisfied with how the game looks in fullscreen. The characters and icons are very small, like we are higher up than in vanilla version (GOG Is there a way to "zoom in" and make the icons and menus biggers, other than playing in windowed mode? (I really hate playing in window mode)
Sorry I know that I'm a couple of years late with this but I just wanted to let you know that there is a solution for this. You can run the game at a lower resolution and use DxWnd to turn the game into a borderless window upscaled to your monitors native resolution.
Kobalobasileus: Once in-game, the hi-res mod works for me, but all of the FMV movies, load screens, and menu screens are still small and centered. Is this the way it's supposed to work, or am I missing something?
Same question. Does someone know how to make the movies scale to fullscreen? (keeping aspect ratio, as set in my GPU settings)
The 0.31 version of ddraw compat did wonders for me.

Can't post links, google this : github narzoul ddrawcompat releases

The game now runs as smooth as butter.

I also installer drogs unofficial patch 2.02
Post edited October 07, 2021 by sabiaq
sabiaq: The 0.31 version of ddraw compat did wonders for me.

Can't post links, google this : github narzoul ddrawcompat releases

The game now runs as smooth as butter.

I also installer drogs unofficial patch 2.02
Oh My GOD. Thank you. the ddrawcompat worked like fuckin magic. Not sure if anything bad will happen, but right away, all good.
dbrownidau: Step 3: Install DxWrapper.
- Extract ddraw.dll and settings.ini into your Arcanum game folder.
- Rename settings.ini to ddraw.ini
This seems slightly out of date compared to the current DX installation instructions
From their site:


1. Download the and unzip it to a folder.

2. Determine which .dll file is needed for the game. This depends on many factors which will be explained on page created later. Most commonly it is ddraw.dll, dsound.dll or winmm.dll.

3. Copy this .dll file from the 'Stub' folder plus the dxwrapper.dll and dxwrapper.ini files into the game's installation directory, next to the main executable file. For some games the main executable is in a subdirectory (like 'Bin', 'Exe' or 'App') so the files will need to be copied it into that directory. Overwriting existing game files is not usually recommended.

4. Open up the dxwrapper.ini file in a text editor and enable the settings needed for the game.

Note: Try the options under the [Compatibility] section first. For many games these are all that are needed. See the Configuration for details on the options.