It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello everybody.

I've fiddled with the game for several hours now, but I seem to be unable to solve a problem with my mouse cursor.

As soon as the game properly starts(so after character creation and the intro vid), my mouse cursor disappears from the majority of the game.
It's still "usable", meaning my character moves to where I assume the cursor is, I can click on dialogue and as soon as I move it to any UI item or open the menu the cursor is there again. Basically, it seems to slip under the games graphics instead of being overlayed on it.

I've traced the error back to the High Resolution patch, since removing it solves the problem, but the low resolution is really offputting, so I don't really want to play without it.

I'm on windows 10
Things I've already tried, non of which worked:
-no3d and -doublebuffer in the shortcut
-all compatibility modes
-reinstalling the game
-trying out both the gog version and the multiverse edition
-software rendering on/off
-other resolutions
-windowed mode
-deleting ddraw.dll

Now I'm starting to run out of ideas. Any help would be appreciated.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Try checking "Disable visual themes", "Disable desktop composition" and/or "Disable display scaling on high DPI settings" in the "Compatibility" settings of the game shortcut.
Sadly Windows 10 got rid of these options.

I managed to find the visual themes deep within the system settings, but disabling them didn't help.
The option to disable desktop compostion is gone completely and the display scaling on high DPI settings can be changed, but not disabled. I tried all options there, again unsucessfully.
avatar
Thovargh: Sadly Windows 10 got rid of these options.
Sorry, I wasn't aware of that: my Windows 10 is up to date, but I haven't noticed those changes as yet.
I based my suggestion on an old thread where I was able to help another user (from Germany just like yourself) in solving the same problem. As you can read there, it solved the issue adding the "-no3d -doublebuffer" parameters to the game's shortcut and this is the most common solution to your problem, but you said you have already tried it. :-/

I'm short on other ideas: maybe you can try playing with the settings of your video driver (forcing or disabling V-sync for the game or similar settings may help), however I suggest you to insist trying with the solutions proposed in the old thread, combining them. I will post them here as well:

- Add the parameters "-no3d -doublebuffer" (without quotes) to the end of your Arcanum shortcut's "Target" field;
- Delete or rename the file ddraw.dll in the game's folder;
- Set a different game resolution with the High Resolution Patch;
- Run the game in a window installing the Unofficial Patch and adding the parameter "-window" (without quotes) to the end of your Arcanum shortcut's "Target" field.
Post edited February 05, 2019 by dr.schliemann