It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Installer, launcher and multiplayer working perfectly fine here!
olafurw: There are two executables/shortcuts in my AVP directory. AvP_Classic.exe and Launch Aliens vs Predator Classic 2000 (Shortcut), both run the game directly. No Galaxy client runs. There is event a Galaxy.dll in the directory so I should have the correct version.
Olde72: After running the installer I had an icon appear on my desktop called Aliens versus Predator Classic 2000 (red icon). The target line for that is: "C:\Program Files (x86)\GalaxyClient\GalaxyClient.exe" /gameId=1207665883 /command=launch /path="C:\GOG Games\AvP Classic"

By contrast, the target line for Launch Aliens vs Predator Classic 2000 reads: "C:\GOG Games\AvP Classic\AvP_Classic.exe"

I don't know if starting up the game from the desktop launcher starts up the Galaxy Client, but I do know that it checks for updates and replaces any modified files. Sounds like a client launcher to me.
1. As a person that never uses desktop shortcuts, this was a strange way to implement the only way to launch the client. Even there is a Shortcut in the AvP directory, why doesn't that one have the Galaxy arguments?

2. Removing the GalaxyClient directory under Program Files and re-running the AvP install is not enough to reinstall, you have to remove the GalaxyClient regex as well.

After a few minutes I get "Galaxy Updater encountered an error and could not continue: Updater could not download update metadata."

I have tried this a few times over the day, even tried connecting through a VPN to see if I can get through there. No deal. I can get the play offline window after the updater error pops up, but not the client.
With the updating on the MP with the launcher will we see possible SP patching as well with the launcher?
I have some doubts direct play is a pitcher and I do not see any client launcher galaxy gog files that take more only on my drive c, this is all style no steam launcher?
tailsy64: The launcher's "Send multiplayer and launcher feedback" link under the More button, does not work. All it does is bring up the GOG support icon (similar to what's found under Start > Programs > > Game Name > Documents for other GOG games). Just a bug I wanted to point out.
pds41: Also encountered on my install. Along with the previously noted annoyance of the update dropping an icon on the desktop.

Personally, I'd also like the option to choose when (if at all) to install updates. Appreciate that defeats the point of the beta test though.
I came here to report the two issues mentioned above.

The "Send feedback" button in the launcher just opens an icon image. And installing an update puts an icon on the desktop even though I unchecked the option to add an icon during installation.
Clicked on " Play " on the Galaxy client . Not worked . Found this error message in the GalaxyClient log .
2014-10-20 16:56:01 [galaxy_client][Error]: Failed launching game System exception; _^‹Ý]‹MU‹ëů
Post edited October 20, 2014 by ne_zavarj
Working great! I think this is an excellent Idea, I can't way to Play Total Inhalation online again!!!!
Minor problem:

I use display scaling on Windows 8.1 to make windows on my screen bigger. (I have a 4k monitor, so I blow everything up to 200% to make things look the same size they would be on a 1080p display.) Unfortunately, the Galaxy client doesn't get any bigger, so it's really small on my screen.

The GOG Downloader program, and all GOG installers, scale up nicely.

I've attached a screenshot to show what I'm talking about. The Galaxy launcher is still perfectly usable, just annoyingly tiny.
capture.png (384 Kb)
pheenix: Right now nothing happens when I use the launcher. The play button greys out after I press it but then nothing. Launching the game manually works, but obviously, multiplayer does not.
I actually have the same problem. Installed the game, ran the Launcher, waited for the update to finish and now I try to start the game with the "Play" button, but nothing happens.

EDIT: Okay, I solved the issue. I had to download and install DirectX 9, now it's working without any problems. I reinstalled Windows yesterday, because my computer was broken, so I was missing DirectX ;p The launcher should give you a message about this tho, instead of just graying out the button and doing nothing.
Post edited October 20, 2014 by maxmontezuma
Game crashes when I played Marine campaign
After installation, the launcher updates itself, then starts.
When I press "PLAY" tough, it just keeps being pressed down, and nothing happens.
I exited the launcher, started again as an admin, did the same, and the same thing happened.
Nothing at all.
Also, it takes a couple of seconds for the client program to start at all.

The game itself however works perfectly fine on it's own.
No issues with the launcher or the game at the moment, I still have to try the multiplayer. Thanks for the game, GOG! :D
My first impressions of the launcher are great. It is simple it updated quickly and I had no problems whatsoever starting the game and getting into a match
Game installed without any problem,
Login worked fine
Launcher updated the game without any issue
Was quickly able to find online game,
Game seems to play fine, good FPS and fast response,
Unfortunately maybe after 1 or 2 minutes I keep get disconnected, I only have a wi-fi connection right now.
The launcher worked perfectly fine. An update was added very smoothly, and then I was able to enjoy the game. It was an easy experience, considering I just had to let the installers and launchers do the work.