It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

maydayp: have you tried making it run with one or two processing cores only, if you think the god clock is running too fast? this causes a crash in heroes of might and magic (you can also find instructions on how to do so in their support page).

also, you've probably already tried this, but, have you turned off visual themes, via compatability settings.
Yeah i tried both, having affinity set to 1 and turning off visual themes. Only thing that made things reasonable is widescreen fix with all vga effects turned off (specially pre-rendered frames) made Zeus worker run now at sort of a normal rate so gods spawn speed is not a big issue now.
if you want to do a reliable test on your setup, load up the "hercules labors' episode and just try building an urchin quay to see if it produces any goods. I think this building relies on some sort of animation sequence to collect goods, that's where my game is always getting stuck on win7.

these are game breaking bugs, I don't think gog should be advertising it as win7 compatible with this kind of problems tbh.
Post edited May 24, 2012 by dosun
For your information, this bug also manifests itself on Linux, running the game under Wine. The game runs perfectly apart from that (did the full first Zeus campaign without a hitch).

Snippet: Wine version and Linux distribution [i]
Σ ~ wine --version
Σ ~ lsb_release -a
Description: Ubuntu 11.10
Post edited June 12, 2012 by GamallIda
No one has a workaround for this? This bug is driving me crazy.

I tried all the windows compatibility settings, I tried disabling everything in my graphics card settings I could think off but the god attacks and spells still take eons to execute. It's really spoiling for me what's otherwise a great game.

EDIT: I got it working reasonably well. The animations are still a bit slow, but they feel about 10 times faster than when I started troubleshooting. They no longer feel broken, just a bit sluggish. They are something I can live with now, which wasn't the case when I started.

What I did was create a custom profile for the game in the Nvidia control panel where I turned off every option that could be turned off, or switched it from a quality setting to a best performance setting, or the setting that it said was best suited to old software, etc etc. Not sure exactly which setting change is responsible for the improvement I experienced, but hopefully this will be enough info to help point others towards their own breakthroughs. Good luck!

Incidentally, I also am using the widescreen fix. The slowdown for the gods was really bad originally for me with the widescreen fix so I'm not sure its really a factor with this bug, but I am mentioning it for completion's sake, in case it turns out to be a more important variable than it appears.
Post edited October 08, 2012 by cgallop
I just got the game, and tried a tutorial mission (the last one, where you are attacked by cyclops). At first, walk animations seemed a bit laggy but were OK. However, when the cyclop attacked Apollo, the latter just looked as if he had a serious backache (he was "blocked").

I've found another way to get him to attack normally (still quite slowly, but it may be on purpose): I've forced DDRAW thanks to Microsoft Application Compatibility Toolkit.

Search for it on Google, then install, and launch the 32bit version of the Comp. Administrator. Right-click on New Database, Create New App Fix. Then fill the fields, and get the path to Zeus's executable. Click "next" twice to reach Compatibility Fixes; search for "Force DirectDraw Emulation". You can do a Test Run now if you want. Then click Next and Close. You'll get a new compatibility fix on the left (Zeus), make sure it's selected, then go to File => Install. You can close the application now. (you can uninstall the fix later on)

Alternatively, I've noticed that going in Window mode (maybe even without the fix) may get your god to act quicker, if need be. Sadly, a Windower like DxWnd doesn't seem to fix the issue by itself (even though it has a pre-configured profile for Zeus).

I hope this will help a bit more.
I have the same issue and this pretty much breaks the game for me because gods are the most fun part of this game. I've even tried playing without graphics drivers but although gods are faster than before, they still aren't as fast as they should be. I searched the internet for hours but noone seems to have a real solution. I sure hope GOG finds a fix for this eventually.
To anyone still experiencing this issue:

Could you please check if Gods' animations are still slowed down on 100% game speed?
Thiev, do you ask because GoG plans to try and fix the bug ? last time I checked running on 100%speed didn't solve it or make it less bad.
aristone: Thiev, do you ask because GoG plans to try and fix the bug ? last time I checked running on 100%speed didn't solve it or make it less bad.
I ask because I think it isn't animations problem but general game speed problem. On 100% animations appear fine on my Win7 - granted, the rest of the game is much too fast.

On slower computers, where 100% looks as it should, the animations are exactly the same.

I'm just gathering information at this point, cannot promise anything solid yet.
Oh, hi Thiev, thanks for the help, I'm redownloading and reinstalling right now to check and help you with as much info as I could. In the years I had the game I gathered some info around(not sure if it applies to the gog release though) if you are interested I can provide all that I can still find if it helps!

I will try as soon as the download finishes to see if at 100% the animations are fine, I usually play at around 70% but I kinda remember that at any speed it was laggy for me.I had read around it's kind of a sierra-related bug and it was common to most of their games due to how the games treated the cpu and probably gpu speed, so quicker ones had issues of slow-downs and such. I really love the fact that you could post about this issue since I really LOVE the game and would do anything to make it work 100% again.

I'll update you soon with all the info I can provide!

edit: I think the site that talked about the cpu bug in sierra games was this

I definitely remember that on some other site I can't find some people tried to "hack" into the game and found that the way the game handled the speed of the 3d animation of the gods had a bug that it made going on overhead and had this "skipping" effect due to the new cpus.It seems either it fell of the google search or it died since I can't now find it. Might be more related to gpu than cpu or maybe a totally different issue, but that was what I'd found.I just downloaded and installed I'm playing a mission right now to get to a spawn and try with different settings!

EDIT2: tried setting on 100% to be fully honest, it felt super-slightly faster, but I kinda think it was mostly a perception issue, since all the whole game is sped up so actually the time it takes probably is comparable. I still guess it0s probably related to cpu cycles or maybe gpu, or some other shenanigans but I'm no expert.I'll reload and try at a super slower speed like 20% and see if it see much slower, or if it is generally consistent.

I definitely noticed an increase in speed at 100% it went definitely faster than at 20-70% but still slow, then stopped, went a bit quick, stopped, etc.If you have a god spawn at 20% speed and change to 100% for a few seconds it still goes super slow like if the speed it was a 20% and then goes a bit quicker. Need any more info? You can tell I'd test anything to have it fixed =P

edit3: found a new interesting thing. loaded up the last advanced tutorial of poseidon, went to look around, cyclops attack, apollo spawns, game was goin at 100% speed. cyclops attacks and moves normally after spawning, I slow down at 70%, apollo spawns SUPER slow, took him more than 40 sec, and now ALSO attacks and behaves super slowly, while generally excluding the blessings/cursing gods for me attack at a reasonable rate.Cyclops is not affected...Didn't have a hero to test, but felt that only the god had major issues...cyclops spawn i did miss but felt surely quicker, or atleast decently quick to be playable...
Post edited December 20, 2012 by Neviskio
I'm seriously considering buying an old pentium 3 computer with windows 98 from ebay just to run this game!
Thiev: To anyone still experiencing this issue:

Could you please check if Gods' animations are still slowed down on 100% game speed?
I've been investigating and the God animations seem to be fine using "Windows NT 4 Service pack 5" compatibility mode. I'm using the Windows compatibility toolkit to do this and the only parameter that makes it perform properly is WinNT4SP5VersionLie. It's the only parameter what makes a difference. Problem is in that mode you get no sound.

Hope this helps to find a solution.

Edit: Hmmm now it's not working. I kept turning it on and off and each time it was on the Gods were fine. Now it's slow again. Also, apparently It turns out that it's hard coded into the game to turn off sound when running in Windows NT because it doesn't support Direct Sound (DirectX 6.1.)

Edit2: Just tried again with "Windows NT 4 Service pack 5" Compatibility mode and the Gods are fine.
Post edited December 23, 2012 by Alfie3000
I am experiencing similar issues with building animations and Gods. Only my gods dont appear on screen at all, they make their announcements, etc but never pop up on screen. If i use the mini map and pinpoint them I can actually right click them and get a response but they never move or show. Sometimes I get their little dust cloud on screen, but thats it.

After reading this thread I went back and checked them all out. Oddly enough, Hermes works fine. He seems to be the only one.
I've experienced the slow gods even with 100% speed. I think the problem got better when I throttled my processor down a few GHz, but even around 1.5 GHz I still had issues.

Any news on this? I will buy so many games from GOG if they fix this problem. Zeus is one of my favorite games ever and having this game-breaking bug has traumatized me for years.
Here are my conclusions after hours of searching for a workaround:

1) Clear behavior:
- in all Sierra city builders (CIII, Pharaoh, Zeus, Emperor), 100% game speed setting won't work as it should under certain circumstances (mostly modern hardware/OS).
- 10% to 90% speed are acting just fine but when you hit the last notch the limiter won't work and your game will just run the faster your CPU can afford. I'd say ~400-600% on a modern PC.
- it's not a problem on CIII, Pharaoh (just acting as a super TURBO mode which can be useful sometimes) but as we now all know, it will slow gods apparition + urchin/fish buildings,etc... on Zeus.
- the faster your CPU can get the slower all those animations will be (example: ~400-600% slower) thus underclocking your CPU will slightly reduce the max game speed and slightly increase those animations speed (as mention before, modern multi-core CPUs are far too powerful so you can rely on this, I went from 4ghz to 1.2ghz and gods animations are still ~200-300% slower).
- auto save will always freeze those specific animations and not the rest of the game (funny timer bug). Just 1-2sec but worth mentioning.

So this is a bit embarrassing because whatever solution we may find to fix those animations speed we won't be able to let all that power unleash resulting in that super TURBO mode we all want (I mean what's the point playing old city builders games if we can't get them faster than before... there're already plenty of laggy modern ones for that).

2) What's the real stuff that is conflicting:
- as someone has mentioned before, running the game with WinNT4.0 SP5 compatibility will make the game running just fine* but without any sound**
*- with a real 100% max speed and therefore 100% correct gods apparition. It's like there's a sound compatibility issue with those games not really a CPU issue. Modern sound card/drivers or directsound break the speed limiter of the game.
**- This is the only effective thing that WinNT4.0 SP5 compatibility will do, disabling all your sound cards and starting the game with all sounds deactivated will do the same (uncheck all sound options before otherwise it'll crash).
- also any application that is using your audio card will break the game again (that's why WinNT4.0 SP5 doesn't seem to work all the time), web browser which use sound will automatically break the game limiter, Steam that uses sounds for chat will do, VLC will also break the game speed limiter but any other application that does not require any sound won't break the game limiter.

So there's definitively a compatibility issue with sound that break the game limiter.

3) Solution:
- I've found that using my motherboard sound chip instead of my PCI card fix 90% of the problem (100% speed is just a bit too fast, I'd say 120% real speed and therefore gods animations looks fine). See ? It's a sound issue... Not that surprising, many old games have sound issues but that was misleading with Zeus (again if any application that support sound is opened on the desktop, it won't work).
- My audio ship is a simple HDAudio (don't know exactly but that doesn't matter), motherboard Asus P5Q-Pro (win7 x64).

****See post below for the correct workaround****

4) don't bother trying:
- virtual machines, not going to work.
- linux+wine, someone told it's the same issue.
- PC emulation with Bochs or QEMU, it should work theoretically but it's a dead end.
- win95/98, it may work but would require your GoodOldRig to work properly which also means terrible performances.
Post edited February 02, 2013 by MoMoune