It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I've tried nearly everything to get this game to work and all I've gotten so far is a load screen that crashes immediately after it appears. I'm on windows 10.
It essentially loads a black screen and then either the loading screens appear (if I change my resolution to 1024) and then it turns into a small black box in the upper left corner and then crashes or if my resolution isn't changed it doesn't show the load screens it just becomes a small black box and crashes.

I've played just Zeus on this laptop before and it was fine so it's 100% Poseidon fucking with me (appropriate really)
I've tried:
All compatibility modes
Changing my res down to 1024 (the only thing that changed anything)
running as admin
re-downloading direct x
launching from galaxy
reinstalling

The only thing I haven't tried is this "widescreen mod" people talked about in earlier threads, I can't find a good link to it anywhere so that's pretty much my last resort before a refund.
Post edited November 22, 2016 by ptorangekatie
No posts in this topic were marked as the solution yet. If you can help, add your reply
Figured out a fix it's pretty brute force though.
Downloaded bink video and deleted in the Binks folder JUST the Zeus_IntroHQ file. I guess it just doesn't run the title intro (which honestly I prefer it's tedious and I skip it anyway)
Should work without downloading bink video codex if you just delete the file. Anyway the game seems stable even in the background, i guess modern computers just don't like running bink files. oh and it's still in 1024 resolution.
Hi, thanks for your tipp. It worked after deleting the videos.
avatar
ptorangekatie: I've tried nearly everything to get this game to work and all I've gotten so far is a load screen that crashes immediately after it appears. I'm on windows 10.
It essentially loads a black screen and then either the loading screens appear (if I change my resolution to 1024) and then it turns into a small black box in the upper left corner and then crashes or if my resolution isn't changed it doesn't show the load screens it just becomes a small black box and crashes.

I've played just Zeus on this laptop before and it was fine so it's 100% Poseidon fucking with me (appropriate really)
I've tried:
All compatibility modes
Changing my res down to 1024 (the only thing that changed anything)
running as admin
re-downloading direct x
launching from galaxy
reinstalling

The only thing I haven't tried is this "widescreen mod" people talked about in earlier threads, I can't find a good link to it anywhere so that's pretty much my last resort before a refund.
WOW deleting the BINKS folder in general is what finally enabled the game to launch for me. I had the same problem as you. Running WIndows 10. Left the resolution at 1920 x 1080 and it runs great.
Am I doing something wrong? Game was worked for me on laptop only (resolution 1920x1080). Then I have plugged big screen with same resolution and game did not running anymore:
- black screen in fullscreen,
- black screen in smaller screen part,
- black screen in smallest screen part
- the end.

I have tried remove the whole folder, but it didn't help. Should I restart gog galaxy or reinstall game or something else?