It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
All other Ys game do, in fact most Falcom PC games run well after you'll install required codecs etc, except Xanadu Next which runs but not really playable because of heavy texture glitches. What about Ys Seven? Does it work in wine?
No posts in this topic were marked as the solution yet. If you can help, add your reply
This is a bit of an old post, but to give it an answer to it, I've just tried to run the game this evening on WINE, using PlayOnLinux, with the latest WINE version.

Pleased to say that it installs and runs, performance is good too, however it seems like the movies don't play and in-game text doesn't appear. I'm trying to find workarounds for both of these.
I just bought Ys Seven a few days ago, after playing through Ys Origin (which worked perfectly). I haven't played any further than the intro video, but so far it mostly works, with some weird glitches related to text placement/sizing/etc. I also found this video online, www.youtube.com/watch?v=El_ky_pJY6Y (I can't post links yet, for some reason?) which has someone playing an hour and a half into it.
Post edited June 14, 2018 by oblume