It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
It's my first time playing Ys 1, should I play the 2001 version (Complete) or the 2009 version (Chronicles)? What is the best version for the first playthrough and why?

Thanks!