It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So, I returned to Memories of Celceta to finally finish the game. Everything worked fine til Danan village. After speaking to elder, he wants to "show something", game starts a cut scene, but that scene never ends. It freezes with all party members approaching a location. From then, all I hear is sound of footsteps while characters are standing still and nothing happened. Even tried to fast forward in case it is a NPC lagging behind, but no - no matter how long I wait, nothing changes. Sufficent to say, this is game breaking glitch.

Anyone else encountered it and found a solution? So far, I tried:

- veryfing game files (Galaxy downloaded additional 111 mb)
- set the game to single core as suggested on different forum - didn't work
- using full screen mode (used borderless window previously) - didn't work
Post edited October 08, 2020 by Bambusek
No posts in this topic were marked as the solution yet. If you can help, add your reply
Fixed. For some reason, Ozma was misplaced in cutscene in higher resolution. Playing the scene in window mode lower res (1024x768 worked for me) fixed it. Finally can proceed
Post edited October 08, 2020 by Bambusek