It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
no matter how i tried, including dgVodoo/ forcing it from the geforce control panel, the game still runs at 120fps and above which is nice and all but its not a stable one and it feels absolutely janky because of it
The only other idea I have is to go into video card settings (like Nvidia settings or whatever AMD uses if you have that kind of video card) and set up a profile for XIII and force vsync. Then the fps will be limited to your monitor's refresh rate.