It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hey guys,

anyone encountered the following message under Linux Mint 17.1 :

./Xenonauts.bin.x86: error while loading shared libraries: libSDL2-2.0.so.0: cannot open shared object file: No such file or directory

I installed all packages mentioned on the product page. Any ideas?

Thank you
Same problem here...

Also I tried to start it up at the same time as you did... Weeks after planned that...

Strange...
I had the same problem on Linux Mint 17.2 and solved it by installing the following package:
libsdl2-2.0-0:i386

Hope this info is of any help to you.
The following packages have unmet dependencies:
libsdl2-2.0-0:i386 : Depends: libwayland-egl1-mesa:i386

If you use LTS Enablement Stacks (ubuntu 14.04.2 14.04.3) (uname -a and check kernel version)
to determinate available:
apt-cache search libwayland-egl1

and install right package
for example:
apt-get -s install libwayland-egl1-mesa-lts-utopic:i386 ibsdl2-2.0-0:i386
("-s" it simulate if all ok - run without "-s" )
I have the same problem on Linux Mint 17.3 64-bit and nothing that's been suggested so far on this thread or similar others has worked.
sudo apt-get install libsdl2-2.0-0

problem solved.
avatar
_Void: sudo apt-get install libsdl2-2.0-0

problem solved.
Thank You a lot, that solved it.