It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I installed the base game through Galaxy and now that I try to launch the game from Galaxy or desktop shortcut, the game simply won't start. After clicking, the play button on Galaxy turns grey for couple of seconds, meaning it registers the attempt to launch, but after the short period it turns back to the default purple.

I tried verify / repair, it downloaded >100MB patch, still won't work. I also tried running both XCOM 2 and Galaxy client as an administrator since in the past similar problem occured with another game and that solved it. Tried compatibility mode for Windows 7, too.

Win 10
3700X
RX 570
No posts in this topic were marked as the solution yet. If you can help, add your reply
And the problem was solved by following the instructions of this message: https://www.reddit.com/r/Xcom/comments/449ijq/vcomp120dll_is_missing_anyone_else_having_this/czoki1y/
avatar
semu: And the problem was solved by following the instructions of this message: https://www.reddit.com/r/Xcom/comments/449ijq/vcomp120dll_is_missing_anyone_else_having_this/czoki1y/
Had this problem aswell. Seems like they forgot to include the redistributable in the download.

A sloppy mistake...
Post edited March 21, 2020 by Dreamia
avatar
semu: And the problem was solved by following the instructions of this message: https://www.reddit.com/r/Xcom/comments/449ijq/vcomp120dll_is_missing_anyone_else_having_this/czoki1y/
avatar
Dreamia: Had this problem aswell. Seems like they forgot to include the redistributable in the download.

A sloppy mistake...
Perhaps it was a condition of the sale, a quid pro quo to Microsoft to demonstrate good faith and derive goodwill for future dialogue?

For posterity, the error reads:


===============
XCom2.EXE —— System Error
The code execution cannot proceed because VCOMP120.DLL was not found. Reinstalling the program may fix the problem.
===============
I didn't download the game until December, but I had the same problem when I tried to launch it. The Play button would turn gray for a second , then nothing. No error messages at all, it just didn't launch. I reloaded, verify'/repaired it. Nothing. I then tried launching it from the XCOM 2 folder without going through GOG. It still didn't launch, but it gave me error messages, telling me it was missing certain dll files. I wrote them down and then downloaded them . I put them in the main folder and stopped getting messages, but the program still wouldn't run. I finally moved the files to the subfolder where the actual application file was located, and it worked. I can play the game with or without the GOG program. Hope this helps.
Not working for me neither :(

Have installed the various VC++ redists (both x86 and x64), and restarted, but no joy.
No logs present, and doesn't work trying to run the pure game exectuable as an admin neither.
Worth mentioning that if I do launch the exectuable manually, I don't even see the error messages people have described above (missing dll related ones), it just doesn't launch or throw errors.

Tried copying the files manually from the reddit post too just in case, but no joy.

Win10 Pro x64
RX 580
Ryzen 3100
You need the x64 ones for sure. I installed the x86 ones first but had to install x64 ones and then it worked.
I got the 2013 C++ for visual here on Microsoft website.
Microsoft artice
id=40784