It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello all, I am having problem with XCOM 2. I was able to play it for quite some time however, the launcher to play the game as well as the exe files found in the binaries folder does not seem to want to work anymore so I tried to do a verify files and repair from the Gog Galaxy 2.0 program. This however did not work as my download got stuck in a loop of downloading to 92% scanning files and then re-trying. Wash rinse and repeat. Does anyone have any other suggestions besides deleting all files and starting from scratch? Thanks in advance for any help.
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
tarjan95: Hello all, I am having problem with XCOM 2. I was able to play it for quite some time however, the launcher to play the game as well as the exe files found in the binaries folder does not seem to want to work anymore so I tried to do a verify files and repair from the Gog Galaxy 2.0 program. This however did not work as my download got stuck in a loop of downloading to 92% scanning files and then re-trying. Wash rinse and repeat. Does anyone have any other suggestions besides deleting all files and starting from scratch? Thanks in advance for any help.
ill copy over the other post to here, but if the varify is stuck at 92%, im not sure. but my fresh download that stoped up dateing at 92% at 70gigs\70gigs did finish.

"ok. mine got near the end, and failed, saying the gog server returned an unknown error.
i did a varyify\retry option, and it resumed, but soon the speed went to min, so i pused it and shut down gog galexy, then resterted and resumed, where it bumped up one %, and went till it got to 92%, at 70\70 gigs.......i left it for a little while (hell, i fired up the xbox), and some time later (30mins to 2 hrs?) it said it was installed. i think i might have pause\restarted galaxy a 2nd time in there somewhere, around 92%, dont remember.
it is now installed, and has 2 exe files, for xcom 2, and xcom 2 wotc. i loaded both up and played part of the 1st level to test and worked so far.

so apperntly they glicthed up with the math somewhere, either galexy, or its adding up the game size wrong...i did see that it started at 68 gigs, for a few moments when first starting it and it was checking the files...but then went to 70gb.

(apperntly tho wotc just adds new enimes\allys\systems to the game rather then a new story? i wasnt aware of that lol)

if you cant get it running, i did see that there is a way to configure your installation, so maybe you can try just doing xcom 2 base first, then adding in wotc, then the rest of the dlc.......at least you wont have to deal with all 70gigs at once that way so if it dosnt work, it wont take as long to find out.

anyway, hope this helps."

edit: i forget i also disabled vast antivirus. (left windows defender running)
Post edited May 14, 2020 by trekstar4444
I am still stuck with this problem. Has anyone solved it yet?
avatar
tarjan95: I am still stuck with this problem. Has anyone solved it yet?
from what i can tell, theres an issue with how it counts. i had an unrealated issue and ended up reseting my whole pc, and redownloaded it again. it went to 89%, 96gb\70gb and stoped advancing while still dling. the next day when i resumed, it bumped to 91% 69gb\70gb, and dl'd, but didnt advance. after some time, it completed. i know it was activly dl'ing, as i checked my network and the usage matched what galxy was saying, so i guess just let it run over night or something. if that isnt working, have you tryied going to the xtras page and downloading the backup offline installers individually, or try useing the website to dl and not use galexy- tbh this is all i can offer.

that said, i might have a diffrent issue with the game this time, so I do think that something is haveing trouble with how it checks and varyifiys this game.
Post edited May 18, 2020 by trekstar4444
Hi all.

Please take a look into this thread to hopefully find a workaround to the GOG Galaxy's client bugged installation.
https://www.gog.com/forum/xcom_2/gog_galaxy_client_installation_workaround
I have reported the issue to GOG.com's support team, but I have not received a reply to my ticket yet.

Cheers.
Post edited June 17, 2020 by Fate-is-one-edge