It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I struggled with this issue for a decent while and didn't find anything regarding it online, so I've decided to write up my findings here (fix in the bottom paragraph).

I found, after installing WA under wine and enabling the wine compatibility options offered on first run, that the game only showed a chunk of the screen when starting a match when "custom resolution" is set. 800x600 windowed worked fine, but when the resolution was set to my desktop resolution, the game would set the correct resolution but only show the top left 800x600 pixels of the screen (messages would get cut off, everything looked to be the right size and location, but the mouse would show anywhere it was moved).

I realized that this was the result of the forced wine desktop, which is automatically set to 800x600.

To fix this, go under the advanced section of the options menu and uncheck "Force Wine virtual desktop", and exit the game. Then open a terminal, set the wine prefix for the location you have the game installed in ("export WINEPREFIX=~/.wine-worms" or wherever you have it), then run winecfg and go to the Graphics tab and check Emulate a Virtual Desktop, and set the resolution to your desktop resolution. Voila! The whole screen will be revealed in-game.
There is also a .reg file in the Tweaks directory, a arguably simpler solution is: install, execute once, activating the tweaks the game offers, leave the game, and execute regedit ForceWineVirtualDesktop_Off.reg.
There was <span class="bold">adamhm's</span>, but it's good to have it in the game specific forum.
avatar
etb: There is also a .reg file in the Tweaks directory, a arguably simpler solution is: install, execute once, activating the tweaks the game offers, leave the game, and execute regedit ForceWineVirtualDesktop_Off.reg.
Good point, I should've thought of checking the tweaks folder for something like that considering I used them to undo my rendering changes.
avatar
Gydion: There was <span class="bold">adamhm's</span>, but it's good to have it in the game specific forum.
Ah, good to know! I'll be checking that thread in the future, especially when the winehq entry hasn't been updated in years. Thanks.
Post edited October 15, 2016 by pbnjoe
Interestingly, even after applying the fix the bug shows when I paint a different terrain.
Can anyone try? Go to "Create a single or multiplayer game," add two human teams, left click in the map so a random one appears, right click and a dot somewhere, play the game.
I can't seem to reproduce that issue; I randomized a map, drew a squiggle around, added 1-UP and 2-UP or whatever they're called, started the game, and it acted like any other, filling the screen...
I did not test extensively, but this wormkit seems to help:
http://worms2d.info/SuperFrontendHD

(I activated the wormkit in advanced options, downloaded the full package, and un packed it in the wa directory)
Oops, I forgot I had SuperFrontendHD enabled. Perhaps that makes it a must-have.
I sent all the info to winehq appdb, hopefully it will appear there soon. Edit, here it is.

Did you try Worms WMD in Wine? I am afraid to buy it because it might not work.
Post edited October 17, 2016 by etb
Nice work! Hopefully that will help people out.

I haven't picked up a copy of WMD, so I can't say, unfortunately.
thanks. I had an older version of wine where everything worked just fine but had the same issues with the newest version. Setting the Engine to WS9Wine1.6-rc4x fixed all those issues for me