It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

After the main menu, I had been having a black screen when clicking "Start" on the main menu on Linux.
Looking at ~/.config/unity3d/Sekai Project/WORLD END ECONOMiCA episode.01/Player.log
I had this error message:
InvalidCastException: Cannot cast from source type to destination type.
at ANovel.StoreData.getFloat (System.String key) [0x00000] in <filename unknown>:0
at ANovel.ANImagerParam.resotre (ANovel.StoreData dic) [0x00000] in <filename unknown>:0
at ANovel.ANImageMaterial.restore (ANovel.StoreData dic) [0x00000] in <filename unknown>:0
at ANovel.GraphicLayer.restore (ANovel.StoreData dic) [0x00000] in <filename unknown>:0
at LayerManager.restore (System.Collections.Generic.List`1 dic) [0x00000] in <filename unknown>:0
at ANovel.ANSaveLoadManager+<loading>c__Iterator0.MoveNext () [0x00000] in <filename unknown>:0
at UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress) [0x00000] in <filename unknown>:0
UnityEngine.GameObject:SendMessage(String, Object, SendMessageOptions)

Solved it by setting the system locale to English. The bug is that in Mono the floating number conversions use the decimal separator for the system locale.
If you encounter this issue, you can edit your script (with any text editor) in the game install directory.
Just add the line
in the
# Game info
section of the .sh script and you can launch the game normally afterwards.

I don't know how to mark that the issue has been solved though...
Post edited December 09, 2018 by Suntorvic
No posts in this topic were marked as the solution yet. If you can help, add your reply
Thank you, that solved it for me! :)