It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

When I start the game I am getting a black screen instead of the main menu (after the three logo screens), does anyone else have this issue and are there any known solutions?

I've tried reinstalling and compatibility modes to no success.

My system is:
16BG Ram
This question / problem has been solved by Genoanimage
I'm having this same problem. BGM plays but after the logos i just have a black screen
Same with me, did someone tried to contact support maybe ? It seems there is a huge problem with the game actually
Same for me. All 3 episodes. Nothing but black screens at the start.

Macbook, MacOS 10.13.

Opened a ticket with support, so we'll see.

EDIT: my bad, only the first 2 episodes, 3rd is okay. Also, fullscreen shortcut doesn't work on ep. 1 & 2.
Post edited November 16, 2018 by Zaroff
Same problem here. Odd that the studio credits at the beginning display just fine but after that nothing but blackness and music. And yeah, the software doesn't seem to understand what "fullscreen" is supposed to mean..

I'm using a Windows 10 box with a GTX 1080 Ti card and a 1920x1080 display -- not a particularly exotic combination.
Same problem here. Episode 2 is the only one that goes into fullscreen for me, and Episode 3 is the only one that is, well, playable. Clicking anywhere on the screen and pressing keys don't appear to make any difference. Hopefully one of you gets a response from support soon. If you do, feel free to update the rest of us in the thread about what's going on.
Post edited November 18, 2018 by Steamed_Hams
Hi guys,

I have an info from the GOG support team:

Please could you go into the game folder. Default:
C:\Program Files (x86)\GOG Galaxy\Games\WORLD END ECONOMiCA episode.01

and delete "save" folder. Next please try launching the game directly from the game's folder using WEE1

After this initial launch you will be able to use GOG Galaxy to launch the game.

It is working for me. Working for both WWE 1 and 2

Post edited November 19, 2018 by erndaft
It looks like this was an issue caused by the cloud saves interfering with the configuration files. Cloud saves were temporally disabled for episodes 1 and 2.

To fix the black screen, please open the Galaxy Client, click the game, click MORE > Manage installation > Show Folder.

On Windows:
Remove the save directory and launch the game again.

On Mac:
Right-click on the WORLD END ECONOMiCA episode.01 select Show Package Contents, remove the save directory and launch the game again.

Same procedure applies to episode.02.

We apologize for the inconvenience.
Fixed it for me.
Thanks for the solution. :D