It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I’ve just finished a Wiz 6-7 playthrough and was planning to import the party into Wiz 8 to continue the fun. I copied the NEWSAVE.DBS file from the Wiz 7 save folder to the Wiz 8 save/import folder. I launched Wiz 8, started a new party and clicked the 7 -> 8 import feature. An error popped up that the file couldn’t be imported because the save game isn’t valid. I went ahead and copy/pasted all of my Wiz 7 save game files to the Wiz 8 import folder to the same effect. Has anybody else had this problem? An fixed? I could just start a new party, but I’d like to finish my 6-8 playthroigh with the same party.
Thanks all.
This question / problem has been solved by townltuimage
are you running Windows 10?
= the wiz 8 save folder is in your documents not the game folder... also files from another system need to be unlocked (right click and properites) before they will import

if you edited the wiz 7 game file then its buggered and will not import... thats the price you pay for using a edit software

however two options remain
this thread has my imported save for wiz 8 https://www.gog.com/forum/wizardry_series/question_about_importing_characters

it has already been imported and fixed (general ending)... new link to my save file = http://nibbit.net/assets/wiz8.7z

another good site for some old save files is http://r0k.us/rock/games/wizardry8/
Post edited July 09, 2018 by ussnorway
Yes, detailed info on OS version etc like game install folder
certainly would allow more than fortunetelling.

Since the import save was apparently visible for the game in the import folder,
i guess the issue is not related to windows bug of moving saves and other updated game files
to a folder where the game/program does not find it at all.
If so the import saves linked by ussnorway, etc, should be accepted by the game,
which would indeed point to flaw in your specific import save.
However i have several flawlessly importing Wiz7 saves edited with dscheat,
characters inventory optimized to the import limits of Wiz8 so i did not have to farm for ammo etc in Wiz7,
and the big majority of them import flawless, while 3 or 4 dont,
so in case "invalid save" may be related to what exactly was changed with ds cheat prog
Thanks to both of you. I’m running Windows XP and I haven’t used any sort of editors. The setup files are in my documents but the game files are not. The save games are showing up when I try to import, they just give the error “Party import failed. The selected file is not a valid save game”.

I imported the same way I imported from 6 to 7; that is, I copied the NEWGAME.DBS file from the Wiz 7 folder to the saves/import folder under Wiz 8. The specific file path is c:goggames/wizardry8/saves/import

I don’t have internet on this laptop, so I can’t download the files that were provided. But I may try to download them to a USB when I’m at work tomorrow.

Thanks for taking the time to respond.
Are you sure that you've got the correct file? I thought that the filename would be SAVEGAME.DBS, not NEWGAME or NEWSAVE as you first mentioned.

Another possibility is that the game can't cope with the Windows path to your import folder. I have Wiz8 installed to C:\Games rather than letting Windows do its own thing, so the savegames are always in the place I expect them to be.
Post edited July 10, 2018 by wavydave
Hi wavydave ;)


Yes Wiz7 default save filename is savegame.dbs,
but Wiz8 appears to scan each file in the \import folder whether it is a valid Wiz7 save,
no whatter what filename or extension.
I .e. i can even see the .zip files on the games import screen, which contain all my Wiz7 saves,
and all my valid saves (=dozens) have different names and/or extensions, else they couldnt be together in a dir anyway.

@borderc

XP and install path sounds good, I assume Wiz8 runs flawless if you use a new party, e.g default PCs.

If those linked files dont work, despite XP etc try to install Wiz8 a 2nd time into a different folder, preferably a new dir,
then run the exe in the new path directly via double click/enter to check your own and the linked wiz7 saves.
If still unsuccesfull copy the new install to another new folder and repeat from there.
If you get any import save working, you can open it with dscheat, along with your own wiz7 save,
from where you take all values and apply them to the working import save.

You can also use a Wiz8 save editor to change any party members to a "legit" Wiz7 import,
as import of nearly all values has fixed rules, only attributed are somewhat random within very narrow bandwidth.
In case go to http://www.zimlab.com/wizardry/recovered/flamestryke/wizardry8/flamestrykes_w8.html
-> Import index, there check all subcategories.
I’m embarrassed, but happy, to report that townltu’s recommendation fixed the problem. Reinstalling the game fixed it right up. Thank you all for your help! Thanks townltu!
avatar
borderc: I’m embarrassed, but happy, to report that townltu’s recommendation fixed the problem. Reinstalling the game fixed it right up. Thank you all for your help! Thanks townltu!
please mark his post as the answer

back to gaming now ;)
Hi townltu ;) Good to see you're still here!

@borderc:

Glad you got things working.